WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Parse error on upgrade

[Resolved] Parse error on upgrade

  • Parse error: syntax error, unexpected T_FUNCTION in /home/example/wp-content/plugins/wp-cms-post-control/inc/wp-cms-class-pcontrol.php on line 119

    Changed the path to give an example of what is happening when I just upgraded your plugin to the latest. Using WordPress 3.6.1 . Not really concerned about the bug on my end since I’m not using the site currently but thought I would note it. If you have any questions for me let me know. Thanks.

    http://wordpress.org/plugins/wp-cms-post-control/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Another important note, this error doesn’t allow activation of the plugin.

    me too got that error after upgrade

    and me too

    SAME HERE!
    I had to downgrade via ftp.

    What kind of hosting is everyone using? I am using godaddy linux shared hosting (not the 4GH hosting, the legacy I believe). Not sure what version php, or if any of that matters, just some thoughts for the author of the plugin. I can turn on/off plugins if needed to see because the plugin is on a website I don’t have currently enabled for the public.

    Plugin Author jonnyauk

    @jonnyauk

    Thanks for letting me know guys – it is actually down to me using a newer version of PHP to test the plugin. I have amended the code to make it backwards compatible now – please update to v2.81 and let me know if there are any more issues – but v2.81 should certainly fix that – apologies!

    Thanks for the quick fix. It’s working now 🙂

    You are welcome jonnyauk, I assumed it had something to do with what PHP I am running under.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Parse error on upgrade’ is closed to new replies.