Support » Plugin: Search Meter » Parse error on line 665

  • Good afternoon. After updating the plugin to version 2.13.1 appears a bug where you cannot open the console of the website. The site itself continues to function. If you deactivate the plugin and activate it later, you receive the error: Parse error: syntax error, unexpected ‘[‘ in */wp-content/plugins/search-meter/admin.php on line 665

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Bennett McElwee

    (@bennettmcelwee)

    I have had no such problem on my sites. Please delete the plugin and re-install it. If the problem does not go away, please reply and I will investigate. Thanks!

    I deleted and re-installed the plugin, but the problem repeated itself. Perhaps the problem is that I have php version 5.2.17.

    Plugin Author Bennett McElwee

    (@bennettmcelwee)

    Yes, that is not good. That version of PHP has been unsupported for years. If possible, you should upgrade to PHP 5.6 or 7.0.

    Thank you for your answer. Unfortunately,the upgrade version of php on my hosting is too labor-intensive operation and I can not do now.

    I’m having the same problem. I’m still using an older version of PHP for the next few weeks or months. Will have to do without the current version of this plugin.

    For anyone who still needs an older version of this plugin, I was able to get version 2.12 to work.

    Same issue here. No way to make it work the last release. Support for older PHP versions would be appreciated.

    After installition the new version of the plugin, I can’t enter to my websit.

    Same problem on my side came up with update to version 2.13.1:
    Parse error: syntax error, unexpected ‘[‘ in /www/htdocs/xxxxxx/wp-content/plugins/search-meter/admin.php on line 665

    After the update no access anymore to the administration-page; only solution to delete or downgrade the plugin via FTP.

    I use the PHP-Version 5.4.45, but it’s not a problem in context with the php-version.
    It’s more probably that it could be a problem in context with the newest WordPress-version, because we saw a strange problem in an other plugin yesterday also.

    With best regards Michael

    • This reply was modified 2 years, 10 months ago by  micha15295.
    • This reply was modified 2 years, 10 months ago by  micha15295.
    Plugin Author Bennett McElwee

    (@bennettmcelwee)

    After a little research, I see that Search Meter 2.13.1 will not work with PHP versions earlier than 5.4. This version of PHP has been unsupported for about a year. Anybody with any version of PHP earlier than 5.6 should upgrade — you already have a year or two of unpatched security vulnerabilities.

    @micha15295, I’m not sure why you had problems with SM. The problem is not due solely to the WP version, since my own web host’s combination of PHP 5.5, WP 4.6.1 and SM 2.13.1 works perfectly.

    I should be able to rework the code to make SM work with earlier versions of PHP. The hardest part is testing — I need to be able to install WP and SM on an old version of PHP.

    I will keep you posted.

    Thanks for your support. Earlier version support would be appreciated since a lot of people have no control on PHP version install. I have already opened a ticket with my hosting provider but I don’t think they will solve in a day or two. Actually my solution was to delete the plugin, but obviously, I would like to keep using it (without removing it from auto-update list).
    Thanks,
    Emanuele

    Everyone who needs an older version can download it here:

    https://downloads.wordpress.org/plugin/search-meter.2.12.zip

    And while it’s true that everyone running on an old system should upgrade, it’s not such a simple change, especially for users who are not tech savvy.

    Nonetheless, as someone who needs to upgrade, I don’t want you to jump through hoops to make the new code backwards compatible. I will be upgrading soon and everyone will be safer when they do figure out how to get on newer software.

    Plugin Author Bennett McElwee

    (@bennettmcelwee)

    I have released version 2.13.2 which I hope will fix this problem. Could you please download it and try it out? Install it using the Upload Plugin button on the Add Plugins screen.

    If this fixes the problem then I will update the stable version. If not, then I will keep investigating.

    Many thanks Bennett, 2.13.2 is running now whitout any problems.

    Thank you Bennett. The newer version fixes the issue and works like a charm.

    Emanuele

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Parse error on line 665’ is closed to new replies.