WordPress.org

Support

Support » Installation » [Resolved] parse error on install in version 3.4

[Resolved] parse error on install in version 3.4

  • I created a mySQL database, added 3 tables and populated them.

    I unzipped wordpress version 3.4, uploaded the files into a wp folder in my http root folder.

    Got a parse error on the first try, so I copied the sample config php file and edited the database information (using the server’s ip address) then uploaded the wp-config.php to the wp folder but still got the parse error below.

    Parse error: syntax error, unexpected T_VARIABLE in /home/content/d/a/s/dasecho/html/wp/wp-includes/option.php on line 225

    Has anyone seen this before?

Viewing 15 replies - 1 through 15 (of 21 total)
  • esmi

    @esmi

    Forum Moderator

    added 3 tables and populated them.

    Why?

    Try re-uploading all files & folders from a fresh download of WordPress.

    Sorry, I’m new to WordPress. I just didn’t want an empty database.

    I just deleted all files and reloaded them. I get the exact same parse error. You’re welcome to type in the URL and see for yourself.

    http://www.dasecho.com/wp/wp-admin/install.php

    esmi

    @esmi

    Forum Moderator

    I just didn’t want an empty database

    Uh?! What does having an empty database have to do with anything?

    1. Empty the database
    2. Delete all files & folders
    3. Re-upload all files & folders from a fresh download of WordPress.
    4. Navigate to wp-admin/install.php

    Okay. I did all that. Same parse error.

    I emptied the database.
    I deleted all files and folders.
    I re-downloaded WordPress 3.4 zip.
    I extracted the files.
    I FTP’ed all the files and folders to the wp directory.
    I browsed the following URL using both Chrome and IE
    http://www.dasecho.com/wp/wp-admin/install.php
    with the exact same results in both browsers and my original browsing.

    I deleted all and re-uploaded now 5 times with all the exact same results:
    Parse error: syntax error, unexpected T_VARIABLE in /home/content/d/a/s/dasecho/html/wp/wp-includes/option.php on line 225

    I’m on godaddy and the mySQL server is different from my website. I don’t think that would cause this.

    Any other suggestions besides re-deleting and re-uploading which takes me over half an hour each time?

    esmi

    @esmi

    Forum Moderator

    I’m sorry but it still looks like you are not uploading all of the files.

    Delete the files and try installing from GoDaddy’s dashboard. It may be an earlier version of WP (like 3.32) but you should have a working, upgradable site. It seems many of the people having problems with the latest 3.4 are on GoDaddy – although I’m sure there’re other hosts where there are issues.

    I’m having the same error. I’m on PHPwebhosting.com.

    Parse error: parse error, unexpected T_VARIABLE in /home/thecave/www/wordpress/wp-includes/option.php on line 225

    I’ve tried re-downloading the WordPress 3.4.zip and reinstalling but I get the same error every time.

    What’s the solution?

    Hi I have also the same parse error installing WordPress 3.4 – it appears the version of PHP I have on 1&1 may be the issue.
    If I update the PHP to 5.2 it may resolve this installation but what about the other 20 sites that have older versions of wordpress v2.8, 3.2 etc. Will they stop working?

    The upgrade feature does not work on certain versions of of wordpress and the manual upgrade for large sites is a long process for all these sites.

    Yes I have exported the download of 3.4 zip and copied all the files up, as I am using the same database for a second wordpress site I copied the wp-config and changed the table_prefix.

    Perhaps I need to download version 3.1 and work with this so the PHP 4.3 will allow the older sites to continue to function until I have upgraded them to a new version.

    esmi

    @esmi

    Forum Moderator

    If I update the PHP to 5.2

    If? WordPress has needed PHP 5.2.4 as a minimum since 3.0. Is anyone else using a version of PHP that is less than 5.2.4?

    An update to my previous entry.

    I have upgraded my PHP from 4 to 5 and the install now works for wordpress 1&1

    Go to Domains & Web Space and under Web Space select Global PHP Version and change from 4 to 5 and save.

    Now go back to the websitedomain/wp-admin/install.php and it works.

    hope this helps.

    PHP on PHPwebhosting is the current 5.3 version.

    esmi

    @esmi

    Forum Moderator

    No problems with PHP 5.3 on any of my sites.

    Since some people doing fresh installs, meaning no plugins are involved, still have problems, it seems there is some issue somewhere between the new WP version or some tweak in PHP that manifests during the upgrade process. What was your upgrade experience like, esmi? Was it all smooth sailing by automatic upgarde?

    Just a FYI. I logged into my host’s dashboard to check my version of PHP, which was 5.2 (not sure which 5.2x). I decided to upgrade to 5.3 and got this message:

    “Upgrading to PHP 5.3 might cause compatibility issues with code on your site.

    “Installed applications might not run under this new version.”

    This is a general warning which may not be applicable to WP but worth noting just the same as we take on this 3.4 updage. There have been five updates to PHP 5.3x between April 26 and June 14, so it’s conceivable that a host could be using a version that has a quirk. The latest releases, “PHP 5.4.4 and PHP 5.3.14 fixes over 30 bugs.” Just saying…

    esmi

    @esmi

    Forum Moderator

    What was your upgrade experience like, esmi? Was it all smooth sailing by automatic upgarde?

    Yes. Locally, I’m using PHP 5.3.3. Live sites (about 9 of them) use PHP 5.3.13. All upgraded without a hitch.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] parse error on install in version 3.4’ is closed to new replies.