Support » Plugins » parse error in Nicer Archives

Viewing 13 replies - 1 through 13 (of 13 total)
  • I checked your narchives.php with mine, and they are the same, so I can’t say whats wrong for sure. You could try deleting the existing narchives.php and try to get a fresh copy and try again.
    Whats the url for the narchives.php on your server, I tried but that didnt work(got a 404)

    I copied your phps, saved it to my wordpress directory and it ran fine. Stumped for the moment as to why you are having trouble.

    And i have trouble running both at home and on my host’s server. I am lost here…

    LaughingLizard, i must appeal to you, as you authored the hack – do you have any idea what is going wrong with my attempts to run it? Lots of people use the hack, i see it everywhere…

    I cannot reproduce the error on any server/machine. I have looked through the code, compared the code between your .phps and mine and everything is exactly the same. I have to say something is happening on your side which is causing this error. Can you give us any other information? Anything else that might be peculiar about your systems?

    Thank you for replying, LL.
    This is very odd indeed, and the error is on a line saying just “global $variable, $variable;” , how can there be a parse error here?
    Well, my ISP’s server runs Apache 1.3.29, and PHP 4.3.3. If you point your browser to , which comes in the WP distribution, you will be able to see all the info about the server’s PHP. I am not sure what could be relevant because i know next to nothing about PHP.
    Also if you go to you will see the error. If there is anything (file, diagnose tool, etc) i can upload to help pinpoint the problem, please tell me and i will.
    I need the nicer archives a lot, because my site is not a blog, so archives by date make little sense to the readers.
    At home i run mac OS X (Darwin Kernel 7.2.o) and PHP 4.3.2, but i don’t have a fixed IP to point you too so you can see my phpinfo, my connection is dial-up. The error shows the same here.

    Okay, one more suggestion. Doesn’t hurt I guess. Go to the end of line 41. After the { press delete, till you remove all the whitespaces/blanks/linebreaks, till the next line pops up and the first letter of the next line comes right next to the {
    Then press enter, save and try running again.
    If that don’t work, try the same with line 42.
    try entering two blank lines before line 42, and see if the parse error Line number changes, and thats a way of identifying what’s causing the error. That’s what all I’d do.

    Ha! That seems to help (removing all identation, i mean). I tried editing on the cPanel editor, the i removed everithing until the “g” from “global” touched the {. When i ran it, the error was in line 42 – that is, the next line, not the one saying “global etc”. So i removed the leading identation from the next two lines (but not the line breaks), and the error went to line 44.
    I guess i will have to do a big clean up. I will post back as soon as i do it.

    sweet! Glad you got it working, had me stumped there for a while!

    There you go 🙂 Strange things fill up the voids in code.

    so that’s all you do?
    just upload the narchives.php and rework your archives link?

    Yep, that’s all you do. If you have tweaked hte index.php menu div, you you the same to the menu div in narchives.php so it stays the same, and it’s done.

    Believe it or not anatman isn’t the only one with this problem. I had exactly the same error on exactly the same line. I’m using Mac OS X as well so that could be the problem.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘parse error in Nicer Archives’ is closed to new replies.