Support » Plugin: CYAN Backup » Parse error in class-cyan-wp-backuper.php line 4

  • Resolved bpbeinlich

    (@bpbeinlich)


    Hello–

    I went to use Cyan Backup today and found that the plugin was no longer working. The main plugin page just displays a blank page. However, the options page displays this error:

    Parse error: syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or ‘(‘ in /home/[…]/html/wordpress/wp-content/plugins/cyan-backup/includes/class-cyan-wp-backuper.php on line 4

    The referenced line says:

    use splitbrain\PHPArchive\Zip;

    My site is running WP 4.3.2 on PHP 5.2.17. Cyan Backup version 2.3.

    I disabled and deleted the plugin, then re-installed it. Same results.

    Any ideas about what might be wrong?

    https://wordpress.org/plugins/cyan-backup/

Viewing 1 replies (of 1 total)
  • Plugin Author Greg Ross

    (@gregross)

    It looks like you have a conflicting plugin installed. Check to see if any of your other plugins are using the PHP Archive library, or disabled other plugins until the error goes away.

Viewing 1 replies (of 1 total)
  • The topic ‘Parse error in class-cyan-wp-backuper.php line 4’ is closed to new replies.