Support » Fixing WordPress » Parse Error, Help!!

  • I was trying to alphabetize the categories on my site, and copied some code off another one of these forums. It didn’t work, and now nothing on our site works. No matter what you do you just get this message:
    Parse error: syntax error, unexpected ‘<‘, expecting T_FUNCTION in /home/jimngilli/ on line 134

    I should just be able to go into my dashboard and delete this one line of code I added, but even our dashboard login gives that message. Help please!!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Can you connect by FTP to edit the file, or can you edit the file through Cpanel?
    If not, you can just re-download the theme (is it this one?), and re-upload it to your server (under wp-content/themes), which will replace the functions.php file.

    Yes, our theme was blend! I wouldn’t mind reloading it, but how can I, when I can’t even log in to my dashboard? We hosted on dreamhost not if that matters…

    I found these options on dreamhost:

    DNS | Visit | WebFTP | FTP | Add IP

    But when I click FTP it says it can’t open the internet site because it is unavailable.

    Am trying to see if dreamhost can restore it!

    You will need to use these instructions to connect to your site using FTP:
    Then download the blend theme from here
    And open up the zip file, there should be a blend folder inside, just drag it to your desktop.

    Then connect to your site with FTP (using the dream host instructions) and go into your web site name, then wp-content, then themes- in here you should see your blend folder. Don’t go into it.
    Drag the blend folder from your desktop into the themes folder. It should ask you if you want to overwrite the file- answer yes (you will need to answer many times) or select overwrite all.

    When this is done, your problem should be fixed!

    Awesome! I can’t even get the FTP to access our website, but I’ll give it a shot. Thank you for helping me, I’ll let you know if it works!

    It doesn’t work. I had already tried connecting through internet explorer’s FTP and Dreamhosts as well. It always just says it is unavailable. On filezilla I get

    Status: Connecting to…
    Response: fzSftp started
    Command: open “” 22
    Command: Trust new Hostkey: Once
    Command: Pass: *********
    Error: Authentication failed.
    Error: Critical error
    Error: Could not connect to server

    But the username and password are what I always use to log in!

    Have a look at this document, it looks like you need to enable Sftp if you’ve never used it:
    If you contacted dream host support, I would bet they’ll do this part for you.

    I tried, but now am getting
    Response: 200 password: you can use ‘quote password’ or Account command (‘ACCT’)
    Status: Connected
    Status: Retrieving directory listing…
    Command: PWD
    Response: 421-Access denied – wrong user name or password
    Response: 421 aborted
    Error: Failed to retrieve directory listing
    Error: Connection closed by server

    even went into Dreamhost and changed the password just in case, but I know I’m using the right one 🙁

    Oh it also says this
    Status: Connection established, waiting for welcome message…
    Response: 220 Check Point FireWall-1 Secure FTP server running on corp_55w_fw1_1
    Command: USER jimngilli
    Response: 331 password: you can use password@password
    Command: PASS *********
    Response: 200 password: you can use ‘quote password’ or Account command (‘ACCT’)

    I got in! And I did everything listed above. The first time I dragged the Blend folder in, it said it transfered files, but never asked me about overwriting. It didn’t work, so I tried again. This time it did ask me about overwriting, but am still getting the original message and am unable to get into my dashboard, or site.

    From what you describe, I think you dragged the blend folder into the wrong location. You’re getting close though!

    When you connect, you need to go into
    You’re dragging the blend folder into the themes folder, which should prompt you to overwrite.
    Because you said that it didn’t prompt you to overwrite, that makes me think that you copied blend into a different folder. Copying it into the folder mentioned above should definitely fix the proble.m.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Parse Error, Help!!’ is closed to new replies.