Support » Plugin: Connections Business Directory » Parse error crashes entire site after upgrade to 8.16

  • Resolved typeless

    (@jbalyo)


    Upgrading to 8.16 crashes the entire website.

    Parse error: syntax error, unexpected ‘::’ (T_PAAMAYIM_NEKUDOTAYIM) in /ommitted/path/wp-content/plugins/connections/includes/class.constants.php on line 23

    PHP version 5.6.33
    WP version 4.9.4

    • This topic was modified 1 year, 9 months ago by typeless.
    • This topic was modified 1 year, 9 months ago by typeless.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Trying to downgrade to 8.15 as an emergency measure and noticed that 8.15 is over 411 MB in size – all other versions are approximately 8 MB. This seems rather suspicious considering its changelog has only one entry.

    What’s going on up there – everything okay? Was this plugin recently purchased by a new vendor?

    EDIT: Okay, it appears like maybe there was a mistake when uploading 8.15 to the archive – the zip file appears to include the entire git repository including copies of every single version ever published.

    • This reply was modified 1 year, 9 months ago by typeless.

    The same thing just happened on my site, using PHP version 5.6.32

    I rolled back to version 8.14, since the archive version of 8.15 is messed up. All is fine again and will hold off on upgrading to 8.16 until the parsing error is fixed.

    Plugin Author Steven

    (@shazahm1hotmailcom)

    Apologies for the trouble!

    I’ve rolled back the stable version to 8.14 so no one else receives the borked zip for 8.15. As for the PHP error in 8.16, that is due to the old version of PHP being run. Unfortunately my local tests did not flag the syntax as invalid for PHP 5.6. I’ll release an update, version 8.17 which will have the corrected syntax.

    Same happened on one of my sites (php 5.6.34)
    Will the plugin be updated automaticly to 8.17?
    I can’t login in the site.

    Or can I just intstall the new version with ftp? No changes in datatbase?

    Great plugin btw 🙂

    • This reply was modified 1 year, 9 months ago by inula.
    Plugin Author Steven

    (@shazahm1hotmailcom)

    @janetb

    This issue has been resolved in the 8.16 version. When did you apply the 8.16 update? Can you confirm the exact error message you are receiving?

    Hi shazahm1,

    Untill this morning (GMT +2) I got this error message with version 8.16:

    PHP Parse error: syntax error, unexpected ‘::’ (T_PAAMAYIM_NEKUDOTAYIM) in /home/xxx/domains/yyy.zz/public_html/wp-content/plugins/connections/includes/class.constants.php on line 23\n

    I did a roll back from a backup of march 15. Everthing was allright then. Still the versionnumber was 8.16??

    Don’t exactly understand what happened, but everything is functioning now and version is 8.16

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Parse error crashes entire site after upgrade to 8.16’ is closed to new replies.