Support » Plugin: Delete Me » Parse error

  • Resolved settorezero

    (@settorezero)



    Plugin gives me the error:

    Parse error: syntax error, unexpected ‘[‘ in wp-content/plugins/delete-me/inc/admin_page_settings.php on line 12

Viewing 7 replies - 1 through 7 (of 7 total)
  • In the profile page of users I’ve another error:

    Parse error: syntax error, unexpected ‘[‘ in wp-content/plugins/delete-me/inc/your_profile.php on line 28

    Can anyone help me?

    Plugin Author cmc3215

    (@cmc3215)

    @settorezero

    Good evening Settorezero,

    Thank you for your error report. This is the first report of this error happening, and I cannot reproduce it with the latest version of WordPress. Would you mind sharing what versions of WordPress and PHP you are using so I can run a more specific test?

    Regards,
    Clint

    grafica.villcom

    (@graficavillcom)

    Hi @settorezero and @cmc3215,

    Same problem for me but I fixed it.

    I’m running WordPress 4.4.2 and I had a PHP version too old for this plugin (5.3). I updated PHP version to 5.6.32 (it’s a stable version) and now it’s ok.

    Hope this is useful for @settorezero too!

    Bye bye

    Elena

    Plugin Author cmc3215

    (@cmc3215)

    @graficavillcom

    Thanks for sharing your fix, Elena. I’m glad to hear you were able to get things working.

    Sincerely,
    Clint

    jmemmott

    (@jmemmott)

    If this is the case, it might be best to update the plugin listing. It currently states that the requirement is “Requires PHP Version: 5.2.4 or higher” which is misleading.

    Plugin Author cmc3215

    (@cmc3215)

    @jmemmott

    Thanks for reminding me about this. I agree with you, and I will update the plugin listing this week after I test and confirm the issue.

    Regards,
    Clint

    Plugin Author cmc3215

    (@cmc3215)

    @settorezero

    Good afternoon,

    I just released an update, version 2.6, that fixes these parse errors. In a recent update, I had made minor use of syntax only valid in PHP 5.4 and up.

    Thanks again for your report.

    Regards,
    Clint

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.