Support » Plugin: Local Market Explorer » Parse error

  • Resolved dw4526

    (@dw4526)


    Help!
    I receive this message when my website comes up:
    Parse error: syntax error, unexpected ‘[‘ in /home/content/d/w/4/dw4526/html/wp-content/plugins/local-market-explorer/modules/market-stats.php on line 74
    It has to do with this line of code:
    $noshowarr = [‘PERCENT LISTING PRICE REDUCTION’, ‘MEDIAN LIST PRICE’, ‘HOMES FOR SALE’,’HOMES RECENTLY SOLD’,’MEDIAN VALUE PER SQ FT’,’HOMES FOR SALE BY OWNER’,’NEW CONSTRUCTION’,’FORECLOSURES’];
    I have had to deactivate the plugin so my website can load

    https://wordpress.org/plugins/local-market-explorer/

Viewing 3 replies - 1 through 3 (of 3 total)
  • I am getting the same error.

    It looks like the way they wrote $noshowarr needs to be changed, it’s assumed that the object is init as an array?

    I changed the surrounded [] brackets to array()

    So line 74 looks like:

    $noshowarr = array('PERCENT LISTING PRICE REDUCTION', 'MEDIAN LIST PRICE', 'HOMES FOR SALE','HOMES RECENTLY SOLD','MEDIAN VALUE PER SQ FT','HOMES FOR SALE BY OWNER','NEW CONSTRUCTION','FORECLOSURES');

    Hello-

    I am seeing this same error on one of my client’s site which actually brought it down…

    Parse error: syntax error, unexpected ‘[‘ in /nas/wp/www/staging/englishteam/wp-content/plugins/local-market-explorer/modules/market-stats.php on line 74

    We have deactivated the plugin for now and will keep an eye on this thread for an update.

    Plugin Author dustin999

    (@dustin999)

    The new 4.1.1 version fix this issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Parse error’ is closed to new replies.