• Resolved artbiz

    (@artbiz)


    After updating the latest release I got this error. I tried to go back a version but it still triggered the error. The plugin can not be activated. Is there a fix?

    Parse error: syntax error, unexpected T_FUNCTION in /home2/jerigrif/public_html/site/wp-content/plugins/nextcellent-gallery-nextgen-legacy/widgets/class-ngg-slideshow-widget.php on line 174

    https://wordpress.org/plugins/nextcellent-gallery-nextgen-legacy/

Viewing 7 replies - 1 through 7 (of 7 total)
  • This is an error with PHP version 5.2.

    I strongly recommend updating your PHP version, as the PHP developers stopped supporting 5.2 about 4 (!) years ago. Contact your host if needed.

    However, I am investigating a fix.

    For now, if you turned back your version, you can delete the file in question.

    Update. I was able to go back a version and activate. But don’t understand why the update crashed on this site but not others.

    Again, since you probably have PHP version 5.2. All sites using PHP 5.3 and up are fine.

    Thanks niknetniko. I’ll have the client contact HostMonster for an update of PHP.

    OK, let me know how it turns out.

    If they still have issues after the upgrade of PHP, feel free to post again 🙂

    Amazing how many hosting companies are still running PHP 5.2, including Go Daddy, Hostgator, all the big ones.

    How do I know this? Because clients are emailing me with crashed sites because of this update.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Parse error’ is closed to new replies.