[resolved] Parse Error (4 posts)

  1. sleeper
    Posted 9 years ago #

    Well then. I have uploaded everything to my domain and every path/password/username stuff is correct. BUT I get parse error when I try the "wp-admin/install.php" thing.

    Parse error: parse error, unexpected $ in /home/theart/public_html/blog/wp-includes/wp-db.php on line 306

    Now I know that parse-errors are little faults in the .php code but I just cannot see how that is possible. I haven´t altered the .php files. I HAVE uploaded them in ASCII mode. So there really shouldn´t be a problem. But there is. Has this happened to anyone else before? [and it´s not just wordpress, the phpbb forum also gives me "parse error"].

  2. schestowitz
    Posted 9 years ago #

    Delete the older files in questions and upload them afresh rather than overwrite them. These issues were reported before. Maybe the datastamp or something else prevents them from being overwritten properly. So, you have a mixture of files from different versions.

  3. sleeper
    Posted 9 years ago #

    Everything works PERFECTLY now! Thank you so much. I want to thank you for anwsering my questions (I have bothered you with this particular question twice). Turned out that the problem truly was my FTP program. I changed programs and now it overwrites the file so that the .php stuff works. So thank you. Happy holidays!

  4. afzalmj
    Posted 9 years ago #

    I am having same error and that is
    "Parse error: parse error, unexpected ';', expecting T_VARIABLE or '$' in /home/content/a/f/z/afzalmj/html/wp-includes/functions-post.php on line 766"
    I may also have problem with my FTP program, so please let me know
    how did you fix the FTP program. If anybody else can help me I
    will appreciate.

Topic Closed

This topic has been closed to new replies.

About this Topic