Support » Plugin: Comments - wpDiscuz » parentId

  • Resolved giulioplay


    Hello, I installed the plugin on Friday. All works fine. Before I had paginated comment (10 per page). Now I set up a 301 redirection from all comment-page to the article.

    The problem is that Google are indexing the #!parentId page. For example,!parentId=12345

    Why it’s happening?

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author gVectors Team


    This is a SEO component for indexing comments.

    This is an SEO disaster – could you please remove or give the option to remove this feature? We want to have the “load more” button, but we don’t want to have multiple instances of the same page indexed in the Google SERPs – that is never a good thing. The comments get indexed via Schema tags already.

    Or at least use a ? instead of a # so we can add it to WMT as a parameter to ignore.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘parentId’ is closed to new replies.