Support » Plugin: Custom Post Type UI » Parent Child URL not found

  • Resolved vtswordpress

    (@vtswordpress)



    actually i used one custom post as a parent of another custom post, when i open the child page its shows 404 error. ex: /post-type/parent-post-slug/child-post-slug

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Michael Beckwith

    (@tw2113)

    can you provide some actual urls, you can leave the domain portion off if you want.

    What are the post type slugs you’ve registered?

    Is it possible that you have a page named similar to the post type(s) in question where it may think you’re trying to reference a child PAGE that doesn’t exist?

    vtswordpress

    (@vtswordpress)

    Actually i have guides(custom post type), for each guides there is number of chapters(custom post type). so the guide act as a parent for each chapters.

    ex: Guide => wordpress-guide
    for the wordpress-guide we have assigned 2 chapters like given below
    Chapters => plugin-chapter
    theme-chapter

    So when we click on individual chapter the URL will be

    http://www.mydomain.com/chapter/wordpress-guide/plugin-chapter

    http://www.mydomain.com/chapter/wordpress-guide/theme-chapter

    so these chapter urls only shows 404 error.

    please help me with this issue

    Thanks in advance

    Plugin Author Michael Beckwith

    (@tw2113)

    Hard to say really without knowing what WordPress is trying to query for.

    Some things to try.

    1. Disable permalinks, and just go back to the “ugly” urls momentarily. If they load fine then, then it’s probably a rewrite/permalinks issue. If it fails then as well, then it’s a content issue with trying to find the information in the install.

    2. If you are simply typing in the URLs based on what is assumed to be the url, instead click to edit the individual posts and use the UI links that get generated by the admin interface and visit them that way. Possible that the working URLs are different than what’s anticipated.

    Plugin Author Michael Beckwith

    (@tw2113)

    Hey @vtswordpress how are things going with this one?

    Hi Michael,
    Actually i fixed this issue with using of category, So now its fine thanks for you suggestions

    Thanks once again

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.