Support » Theme: IAMSocial » Parent Button does not work with sub menu

  • Hallo!
    Please, look at this: http://legelos.de/gzvcelle/
    The primary menu item “Verein” does not work together with the sub menu. The top level (parent) menu item should call its own page, but a click on it shows only the sub menu. Without a sub menu it works.
    For comparison: The menu in the footer works correctly.
    Anybody an idea what´s going wrong? Is it a bug?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Bonjour, j’ai le même problème que heikl. Le menu principal de l’entête ne fonctionne pas lorsqu’il y a un sous menu.
    J’ai peut-être une piste pour résoudre le problème. Le menu principal affiche le sous menu pendant le chargement de la page, tant que la police de caractère n’est pas encore changée. Puis il ne fonctionne plus à nouveau lorsque la page a été chargée, et la police changée.
    Merci d’avance pour votre aide.

    Theme Author aicragellebasi

    (@aicragellebasi)

    Hi guys.

    Sorry about this issue. Thanks for catching it.
    I am going to try to find a way to solve this soon and will push an update of my theme.

    Thanks for your patience.

    Hi Isa (@aicragellebasi),

    before you start working on this issue 🙂
    Could you please make an option if it? For me it works just fine, when the parent menu item doesn’t open it’s own page but only the sub-menu. By setting an option for each parent menu item, this behaviour could be toggled.

    Btw is this the same issue when class for the parent menu item is not set as active (color highlight) if a page from the submenu is selected? The active class is only defined if there are no sub menus…

    Regards,
    Jack (@dutchmanjack)

    Theme Author aicragellebasi

    (@aicragellebasi)

    Hello Jack,

    I am not sure to understand what you want. Can you clarify please?

    I thought of something, IAMSocial is on Github. You can contribute to it if you want. Maybe you want to add your fix and push it so that I can take a look at it?

    Honestly right now, I have absolutely no time to take care of this. But I would be happy to take some time to look at your code if you have a solution for it.

    Thanks

    Hello Isa (@aicragellebasi),

    thanks for answering so fast 🙂 I signed up at github, had a look at it but frankly I’m sorry to say that I’m not firm at that. Please give me some time to send you an email to explain what I mean.

    Regards,
    Jack (@dutchmanjack)

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Parent Button does not work with sub menu’ is closed to new replies.