Support » Fixing WordPress » Parent attribute missing

  • I have updated from 3.01 to 3.03

    When i add a new page, the parent attribute is missing from page attributes. There was the ability to set a page as a child of a existing parent page but this has disappeared.

    I had set the page structure up previously and the structure seems correct.

    I have bulk edited pages from draft to published and back again, plus been logged on at same time as a new author user if this helps diagnose

    I have more pages to create which are sub menus/child. Any help appreciated.

Viewing 5 replies - 1 through 5 (of 5 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems?

    this is with the default template and no plugins apart from askimet

    it seems to come back when all pages are made ‘published’

    parent attribute is not available when creating new pages or editing pages which are in draft

    As the site is new and pages are being written. Is it meant to be like this as standard????

    esmi

    (@esmi)

    Forum Moderator

    Is it meant to be like this as standard?

    No.

    Try:
    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    – increasing the memory available to PHP:
    http://wordpress.org/support/topic/253495#post-1017842

    Tried again, deleted and uploaded fresh wp-admin and wp-includes folders from a fresh download.

    Parent attribute is not available until at least one page is live/published.

    So not sure if it is a bug or by design. ie how can a page be a child if there is no parents?

    However, the parents are created, just in draft form. Suppose i will just have to create all pages and organise structure afterwards when we go live.

    esmi

    (@esmi)

    Forum Moderator

    Parent attribute is not available until at least one page is live/published.

    I think that would be normal behaviour.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Parent attribute missing’ is closed to new replies.