Support » Theme: Sketch » Parameter 1 to wp_default_scripts() expected to be a reference

  • Hello!
    On the latest WP I get this when using the Sketch Theme.

    Parameter 1 to wp_default_scripts() expected to be a reference, value given in /var/www/thomaseje.dk/public_html/wp-includes/plugin.php on line 601

    And I find a lot of other Sketch sites with the same error when searching on google with the frase: “Parameter 1 to wp_default_scripts() expected to be a reference, value given in wp-includes/plugin.php on line 601”

    When I´m logged in it´s not there.

    How do I/We fix that?

    Best Thomas

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi Thomas,

    I can see the warning messages you are referring to. There are two at the top of the site and they both reference /wp-includes/plugin.php. The warnings appear to be generated by Core WordPress and unfortunately, don’t contain any more information so I’m unable to say exactly what is causing them.

    I installed Sketch on a brand new test site but wasn’t able to replicate what you are seeing — which suggests this being caused by something unique to your site (and the others you have found).

    PHP can execute with multiple warnings and PHP error would cause the site to crash/load a white page only containing errors. The warnings you are seeing can be hidden by turning off error reporting.

    On the latest WP I get this when using the Sketch Theme.

    This implies the warnings weren’t being displayed prior to updating WordPress, is that correct. It looks like you are currently using WordPress 4.5.16 so I recommend updating to the latest version (5.0.2). Also, are you using the latest version of Sketch (1.2.4)?

    Hi Gemma.

    I believe the webhost stopped support of php 5.3-5.5 and that is the reason.

    What PHP version are you on?

    I´m on 5.6 now.

    Best Thomas

    Hi Thomas,

    There is some information about server requirements for WordPress here:

    https://codex.wordpress.org/Template:Server_requirements

    Servers running PHP version 7.3 or greater and MySQL version 5.6 are recommended for the latest versions of WordPress (see the download page).

    This forum is theme specific but there are other WordPress.org support forums you can post to for advice about hosting requirements:

    https://wordpress.org/support/forums/

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.