WordPress.org

Support

Support » Plugins and Hacks » Edge Suite » [Resolved] Parallax problem

[Resolved] Parallax problem

  • Hi,

    I’m back with a question about Sarah Justine’s javascripts for EA. But not the resize/responsive script this time, which works perfectly thanks to you.

    It’s about a parallax effect that she has created (think it’s called that) that once again works when previewed in a browser from EA, built not when imported into WordPress via the EA plugin.

    The effect can be seen here, and it’s the effect that occurs when you move your mouse over the animation, i.e. the different image layers (the clouds) moves with the mouse:

    http://sarahjustine.com/demos/scaletofit/

    I plundered Sarahs EA files (provided on her web site) for the javascript that makes the effect and inserted them into my own animation:

    creationComplete

    // Control the timeline with the mouse cursor
    this.onMove = function( posX, posY ){
    timelineControl = Number(posX)*10;
    sym.stop(timelineControl);
    }

    mousemove

    // Playback the timeline based on the position of the mouse cursor
    this.onMove( e.pageX, e.pageY );

    Worked perfectly when previewed in a browser from within EA. So I the made an .oam file and then imported it in WP:

    http://nordicgreen.cag.se/sv/

    The animation plays but jumps to the end on mouseover and stops.

    I tried this:

    <div style=”width:100%; height:auto”><div id=”Stage” class=”EDGE-17912770″></div>

    but it didn’t work.

    Is there some special code that needs to be inserted to make the animation work in EA?

    Thankful for any ideas!

    Regards
    Johan

    http://wordpress.org/extend/plugins/edge-suite/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author ti2m

    @ti2m

    By looking at the animation in chrome it seems to work. At least the background moves with the mouse. Or what is it supposed to do?

    Plugin Author ti2m

    @ti2m

    I’m marking this as resolved, due to inactivity, feel free to reopen.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Parallax problem’ is closed to new replies.
Skip to toolbar