WordPress.org

Forums

Paragraphs Lost when Visual Editing Mode Turned On (10 posts)

  1. sassymonkey
    Member
    Posted 7 years ago #

    I'm having a new problem after installing WP 2.3 with the "Visual" and "Code" editing modes that cause paragraph spacing to be lost.

    When switching between editor modes, the paragraphs are stripped away. Also, simply editing a previous post will call up the post in the "Visual" mode and the paragraphs are lost.

    For example, this post content:

    Hello World!

    WordPress is great!

    ...turns into:

    HelloWorld!WordPress is great!

    I had to turn visual editing off altogether even though I use it sometimes.

    Anyone having this problem too?

  2. TokyoJimu
    Member
    Posted 7 years ago #

    Yes. I installed 2.3 (upgrade from 2.1.3) today and now have this exact problem. Once I edit a post, all paragraph breaks are gone. I even tried manually adding HTML code back in "Code" mode, but as soon as I save it, they are gone, as are the paragraphs.

    I tried going back to the default theme, but this made no difference. How do I turn this off?

  3. invalidname
    Member
    Posted 7 years ago #

    I have this problem too (I'm on a Mac... is it the old "CRLF must be right because that's what Windows does" logic?), and noticed this misbehavior when I switched browsers from Shiira to Safari.

    The worst thing is that I would be happy to just use Code view and edit my breaks manually, but every time I go into edit a post, it defaults me to Visual view and destroys all my paragraphs. Heck, I'd be happy just to be able to default to Code view, or to remove the Visual editor, regardless of whether the Visual editor can or will ever be fixed in this respect.

    -Chris

  4. Jeremy Clark
    Moderator
    Posted 7 years ago #

    You can disable the visual editor. go to your dashboard and up in the top right corner click the link My profile then uncheck the box labeled use visual editor.

  5. invalidname
    Member
    Posted 7 years ago #

    jeremyclark13: thanks for the awesome tip. Stupid frickin' visual editor is dead to me now.

  6. meatleg
    Member
    Posted 7 years ago #

    HELL YEAH!
    that rocks. stupid visual editor...
    thought i would have to load safari 2 back onto leopard to work in WP...
    thanks for the tip!

  7. JoyrexJ9
    Member
    Posted 7 years ago #

    Is this going to be fixed?

    The WP guys seem to be ignoring a major bug. I've had to disable the visual editor, as it's now unusable.

    Even a work-around would be nice!

  8. jiphex
    Member
    Posted 7 years ago #

    I'm also having this problem with 2.3.2 (new install today).

    Very annoying.

  9. eric_anderson
    Member
    Posted 7 years ago #

    I agree. I was really excited that the new editor worked in Safari however this bug is very frustrating.

  10. marko7
    Member
    Posted 7 years ago #

    The problem is in the browser you use. The main rule is never to use Safari when posting on WordPress.

Topic Closed

This topic has been closed to new replies.

About this Topic