Support » Plugin: Subscribe To Comments Reloaded » paragraph tags in non-HTML mail

  • Resolved JarkkoL

    (@jarkkol)


    The paragraph tags <p> are incorrectly included in non-HTML notification emails. How can I disable these tags for non-HTML notifications? In the default messages where the link is the last “word” in the message the end-of-paragraph tag is merged to the link as well which kind of sucks.

    I tried remove the tags from “Tools -> Source code” but they are always added back ):

    Thanks, Jarkko

    https://wordpress.org/plugins/subscribe-to-comments-reloaded/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Reedyseth

    (@reedyseth)

    Hello @jarkkol,

    The paragraph tags <p> are incorrectly included in non-HTML notification emails. How can I disable these tags for non-HTML notifications?

    Can you show an example of the result?

    Is there a special reason why you need a non-HTML notifications ?

    Regards.!!

    non-HTML is the default behavior of the plugin and I assumed this is the preferred setting due to more widely support by email readers. Anyway, I’m using HTML now because of this bug. I got this specifically for “Double check message”, but I presume it happens for other messages too.

    You can easily replicate this issue by switching off the HTML notifications and you’ll get something like this:
    <p>You have requested to be notified…. click the following link: http://plapla.com/plaplapla</p&gt;

    Outlook and iOS consider the tailing </p> to be part of the link. As a quick fix I tried to add space there after the link but it’s stripped out.

    Plugin Author Reedyseth

    (@reedyseth)

    @jarkkol

    non-HTML is the default behavior of the plugin and I assumed this is the preferred setting due to more widely support by email readers.

    The reason of this is because the none HTML message are just text, so in order to have a nice HTML email you have to setup the email headers (this is what the plugin does for you), but you have to enable the HTML email in the options.

    You can easily replicate this issue by switching off the HTML notifications and you’ll get something like this:
    <p>You have requested to be notified…. click the following link: http://plapla.com/plaplapla</p&gt;

    So there is an option to remove the <p> tags completely from the editor, on this case you have to change a bit the code, if you still need this let me know and I walk you through.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘paragraph tags in non-HTML mail’ is closed to new replies.