WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Paragraph spacing

[Resolved] Paragraph spacing

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author benz1

    @benz1

    I just did a simple test using the following html in a global content block:

    <p>line 1</p>
    <p>line 2</p>
    <p>line 3</p>

    and it appeared correctly on the page.

    The plugin does not remove p tags. Maybe it’s a setting on your editor?

    I think what rbart may be saying is that if you use normal WP visual editor keystrokes like hitting Enter to create a paragraph, or Shift + Enter to create a line break, these do not function on the plugin’s Tiny MCE. I am having the same issue because I would like to allow my client to use this plugin, but he knows nothing about HTML. Perhaps I’m missing something?

    Plugin Author benz1

    @benz1

    The visual editor in the plugin will mimic the standard post/page visual editor functionality (it uses the same function). The abiility to add content without the VE stripping out the formatting is one of the reasons I created the plugin but yes, this would require the contnet to be added in HTML mode.

    The trick I usually use inthe VE to force it to keep a line/paragraph break is to put a period (full-stop) on the line and color it the same as the background so it’s not visible.

    I have the same problem. Are there any plans in a future update to allow for the visual editor to work with line breaks / paragraphs?

    Plugin Author benz1

    @benz1

    This is an issue with the WP visual editor and beyond the control of the plugin. If you use the HTML/Text mode of the editor you will have no problems. If you use TinyMCE Advanced I believe there is an option to prevent the editor from stripping out breaks.

    Unfortunately I’ve met the same problem. In text editor I added 2 paragraphs like:
    <p>line <span>1</span></p>
    <p>line 2</p>
    Went to visual editor which shows the path like Path: p, or Path: p >> span. But when I go to the text editor again, it shows

    line <span>1</span>

    line 2

    So <p> tag is missing. And it is also missing on the page where I put this code [contentblock id=1]

    Plugin Author benz1

    @benz1

    As per responses above this is an issue with the WP editor. If you stick to the text view and don’t switch to visual while creating the content block you shouldn’t have a problem.

    I’ve just checked the other visual editor tags like list or headings or address – all of them are working, but not the paragraph. It disappears.

    That works. Thank you benz1!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Paragraph spacing’ is closed to new replies.