Support » Plugin: WP Redis » Pantheon Lando: ERR AUTH warning version 1.3.2 and above

  • nmaine

    (@nmaine)


    Since 1.3.3 came out I can’t upgrade. I get the warning I’m pasting below. I’ve tried up to 1.3.5 and this warning won’t go away. I’m pretty sure Lando doesn’t use a password.

    Is there a way to silence this without actually disabling warnings? Any suggestions? I don’t want to actually configure Lando to use a password. I’m running the latest Lando and this is php 8.

    Warning: WP Redis: ERR AUTH called without any password configured for the default user. Are you sure your configuration is correct? in /app/wp-content/plugins/wp-redis/object-cache.php on line 1428 

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Chris Reynolds

    (@jazzs3quence)

    To be clear, this error is happening locally with Lando, specifically, is that correct? Do you have an object-cache.php file in /wp-content?

    Thread Starter nmaine

    (@nmaine)

    Hi @jazzs3quence, yes this is a Lando issue and I do have object-cache.php in wp-content. I even copied the latest object-cache.php over just in case it changed. I suppose it’s Redis producing the error as that error string isn’t in the wp-redis code. I’m sure if I deployed my code to Pantheon this wouldn’t happen as they have passwords. It’s just the error is hard to work with locally.

    Plugin Contributor Chris Reynolds

    (@jazzs3quence)

    Got it, just wanted to confirm so that we know how to reproduce this locally. Thanks for the feedback!

    Plugin Contributor Chris Reynolds

    (@jazzs3quence)

    Just wanted to circle back to this.

    @nmaine We pushed out an update a couple days ago (1.4.2) and neither I nor our QA engineer were able to reproduce the issue on the latest version. This is the process I followed to try to reproduce:

    • create a new site (bugs-6180)
    • terminus local:clone the site
    • lando init using the pantheon recipe
    • installed the WP site
    • installed wp-redis and terminus wp bugs-6180.dev -- redis enable to create the object-cache.php drop-in
    • pulled the database and code down locally
    • ran lando wp redis info and saw the expected output

    Let us know if you are still having the issue and what steps might be required to reproduce beyond the above. The 1.4.2 update fixed a couple other things, and I was seeing similar issues locally prior to the fix, so I think it was solved in the latest version.

    Issue tracked internally as BUGS-6180.

    Thread Starter nmaine

    (@nmaine)

    Hi @jazzs3quence I only get this issue with my current WordPress Pantheon Lando project, my other projects are fine. I tried the latest release and the password issue still persists. This is only happening on Lando, I pushed the updates to Pantheon and wp-redis run fine. I updated Lando and also destroyed/rebuilt the project and that hasn’t made a difference. I’m also not doing anything custom in my lando.yml file.

    Your steps are basically the same as mine. You have been super helpful and thorough, this seems like there may not a solution.

    Thanks, Nick

    @nmaine are you running an M1 Mac?

    Note that this is _probably_ primarily an upstream Lando issue that’s being tracked here: https://github.com/lando/pantheon/issues/147

    Thread Starter nmaine

    (@nmaine)

    HI @reynoldsalec I am running an M1 Mac, and have had issues with the Pantheon recipe since I got this computer. I can’t run lando pull for example. I have an open issue for this. I am also running a Pantheon Multisite with the same recipe and have had no issues when I update wp-redis, I’m on the latest version now.

    I’ll try those ideas in the issue thread, I can also add comments to that thread.

    Thanks for the helpful replies.

    Thread Starter nmaine

    (@nmaine)

    Hi @reynoldsalec This solution worked for me, the warnings are gone. I’ll go with this for a while.

    https://github.com/lando/pantheon/issues/147#issuecomment-1549082433

    Cheers

    Plugin Contributor Chris Reynolds

    (@jazzs3quence)

    @reynoldsalec So this is an issue that only affects M1 Macs?

    Based on aarow’s findings on the GitHub issue I believe that is the case…need to dig a little deeper myself to find the underlying problem.

    Plugin Contributor Chris Reynolds

    (@jazzs3quence)

    @reynoldsalec 👍 Thanks for jumping in. I’d like to do some testing on our end, too, but I also don’t have an M1. 😅

    Hi @nmaine! Can you confirm if this is still happening with Lando 3.18.0 and above?

    https://github.com/lando/pantheon/issues/147

    • This reply was modified 3 months, 3 weeks ago by Scott Buscemi.
Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.