WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Pagination Problem

[Resolved] Pagination Problem

  • rikinhobr
    Member

    @rikinhobr

    Guys, I have a problem with pagination.
    My site have sessions (index.php?s=NAME)
    and I linked the WP in “/blog/home.php” (the URL is index.php?s=blog/home)
    but when I click on “next page”, the page doesnt exist.
    The URL: “blog/index.php?s=blog%2Fhome&paged=2”
    should be “index.php?s=blog/home&paged=2”

    How can I do?

Viewing 8 replies - 1 through 8 (of 8 total)
  • s_ha_dum
    Member

    @apljdi

    This chunk blog%2Fhome is urlencoded. You need to urldecode it.

    rikinhobr
    Member

    @rikinhobr

    no,
    I mean, I want to delete the “blog/” in URL.
    is “blog/index.php?s=blog/home&paged=2”
    I want “index.php?s=blog/home&paged=2”

    s_ha_dum
    Member

    @apljdi

    Where is WP installed? Is it in the ‘blog’ directory? Do you have an URL?

    rikinhobr
    Member

    @rikinhobr

    yes.
    the WP is installed in the blog directory..
    -> http://www.twidot.com.br/blog/
    but I linked teh posts of WP in my site

    Mark Ratledge
    Forum Moderator

    @songdogtech

    If you want to make the blog appear as though it’s not under /blog/, you’d probably need to do something like http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory but only use the steps that involve setting it up in a new directory and moving your index.php

    rikinhobr
    Member

    @rikinhobr

    Thanks guys,
    thank very much!!!

    \o\

    s_ha_dum
    Member

    @apljdi

    If WP is in the ‘blog/’ directory its going to want that ‘blog/’ in the URL.

    I think there are some things I don’t understand about your what you are trying to do.

    1) Are you linking from the main site to the blog?
    2) Are you linking from the blog to the main site?
    3) What is generating these links?

    Not to be paranoid, but I worry about the way your site includes files. I’ve been able to get some interesting results by playing with the URL, though I haven’t got to anything critical yet I’m pretty sure I could. Try this for example:

    http://twdot.w1host.com/index.php?s=blog/wp-config.php); %00

    That really shouldn’t happen. (You’ll have to copy the whole line to get it to work.)

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Pagination Problem’ is closed to new replies.