WordPress.org

Forums

Pagination on the single.php template (4 posts)

  1. dcarroll
    Member
    Posted 4 years ago #

    I'm having a bit of a (recent) problem with posts that are split into separate pages using <!--nextpage-->. On each of the split posts, clicking any of the pages (e.g., 4, 3, etc.) simply reloads the first page. The URL bar in the browser (doesn't matter which browser) at first shows the page requested (e.g., /blogpost/2/), but changes during load and displays the permalink instead (e.g., /blogpost/).

    Example here: http://northridgemedia.net/blogs/create/departments/inspiration/how-its-made-recycled-frame-chalkboard/.

    Poking around Google results, it looks like most of the problems relate to custom queries, which I'm not using at the moment. I'm using a pretty basic single.php, like below:

    <?php the_content('<p>Read the rest of this entry &raquo;</p>'); ?>
    			<?php wp_link_pages(array('before' => '<div id="postpagenav"><ul id="ppn"><li><strong>Pages:</strong></li> ', 'after' => '</ul></div>', 'next_or_number' => 'number' , 'link_before' => '<li>' , 'link_after' => '</li>')); ?>

    Any thoughts?

  2. dcarroll
    Member
    Posted 4 years ago #

    Update: this is a live blog, and the link given above no longer has the problem (nextpage tags were removed). I'll look for something they've published in the past to see if I can get another specific URL.

  3. dcarroll
    Member
    Posted 4 years ago #

  4. Cole Slaw
    Member
    Posted 4 years ago #

    I desperately need help with this to. It must be something with the rewrite rules??

Topic Closed

This topic has been closed to new replies.

About this Topic