Support » Plugin: WooLentor - WooCommerce Elementor Addons + Builder » Pagination on homepage not working

  • Resolved mrniceguy007

    (@mrniceguy007)


    Hello,
    I’m having trouble getting pagination to work.
    What I did:
    1) Install WooLentor
    2) In Elementor Templates, created new Page template (Elementor, full width) -> Edit with Elementor
    3) In Elementor editor added WL: Product Archive Layout (Default) -> customized some style and in Content tab on Pagination = YES
    4) On Dashboard -> WooLentor -> WooCommerce Template -> Product Archive Page Template = The page that I just created in step 2
    5) Create new Page (called Home) -> edit with Elementor
    6) In Elementor editor Add Template -> My Templates -> the one created on step 2
    7) Dashboard -> WooCommerce -> Settings -> Products -> Shop Page = page from step 5

    At this point, everything is working normally. All products are shown in order and pagination is working.
    However, if I set the page Home as homepage, suddenly pagination stops working. Page numbers are shown and url is changing but content stays the same.

    You can see that from the links I provided. The first one is just base url to the website and the page Home is set as homepage. The other link is to the page Home itself where pagination works normally.

    Am I missing something in the process or can it be fixed?
    Since the url is changing to domain/page/2, my guess is the pagination buttons are missing domain/home/page/2 or some other workaround.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author HasTech

    (@devitemsllc)

    Hello,
    Sorry for inconvenience.
    You are right in static Home page number pagination not work. See end of this https://codex.wordpress.org/Creating_a_Static_Front_Page
    Thanks

    Thread Starter mrniceguy007

    (@mrniceguy007)

    Hello,
    thanks for a fast replay.

    After a long research, I finally found solution (sort of):
    https://gist.github.com/lauhakari/5089252

    By adding this function and setting pagionation_base = “home/page” where “home” is the name of my homepage, I was able to get pagination to work on homepage.
    Just a suggestion for WooLentor, it’s amazing plugin by the way, if you could put that feature somewhere in WooLentor settings, like turning on pagination on homepage.

    This is now working on WooCommerce 4.1.0 and WooLentor 1.6.1

    Plugin Contributor HasThemes

    (@hasthemes)

    Hello @mrniceguy007
    Thank you for your message.
    We will check it and try to add this feature very soon.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Pagination on homepage not working’ is closed to new replies.