Support » Plugin: WooCommerce » Pagination on categories not working

  • Resolved ettermanenterprises

    (@ettermanenterprises)


    The main categories are not paginating like the subcategories are.
    Here is the link to a main category:
    Tube Host and Fittings
    As you can see it just keeps going when I have it set to 3 products per row and 4 rows per page.
    Here is a link to the subcategory that works perfectly.
    Hydraulic Parts

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Cara – a11n

    (@dcka)

    Hi, @ettermanenterprises!

    The lack of pagination in the category page would normally be a function of your site’s theme. From the code, it looks like you’re using the Sinatra theme. If I got that right, you can ask your question in the theme’s dedicated forum here: https://wordpress.org/support/theme/sinatra/

    Alternatively, to help confirm if it is indeed an issue with your theme, can you see if pagination works when switching temporarily to Storefront?

    Thread Starter ettermanenterprises

    (@ettermanenterprises)

    I originally tried switching to storefront and it did the same thing. I did go to Sinatra support and that is what they had me do. And it still acted the same way.

    Plugin Support Cara – a11n

    (@dcka)

    Hmmm…. you may have Infinite Scroll enabled.

    Can you please check under Settings > Reading if you have a setting there for infinite scroll? If yes, please see if disabling it helps.

    Alternatively, if your site is using Jetpack, you may also want to look for the Infinite Scroll setting under Jetpack > Settings > Writing.

    Thread Starter ettermanenterprises

    (@ettermanenterprises)

    Jetpack is set to “Load more posts using the default theme behavior”. So I played with the other two settings and did not like them in Jetpack and changed it back to use “Load more posts using the default theme behavior” and when I went to re-check my site pagination now works… odd but it seems to be fixed. Thanks for making me check this setting! I appreciate your help very much!

    Plugin Support Cara – a11n

    (@dcka)

    You’re very welcome! Even though we don’t know which setting exactly worked in your case, I’m glad that helped. Thanks too for keeping us updated!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.