Support » Plugin: WP RSS Aggregator » Pagination not working depending on permalink setting

Viewing 13 replies - 1 through 13 (of 13 total)
  • I have exactly the same issue.

    I think the problem is wp-rss-aggregator is always looking for page=x. The problem is that with the “Post Name” permalinks, the page=2 gets rewritten to /page/2 in the wp-rss-aggregator pagination which doesn’t work.

    On my test site, if you go to http://www.pbdigest.com/test/page/2 you get redirected back to the home page, if you go to http://www.pbdigest.com/test/?page=2 it works fine. I need to do some digging around the code to see if I can figure out what is going on. At first glance it looks like wp-rss-aggregator is doing url parsing and looking for page=x instead of using the GET variables from the request.

    Hopefully that helps someone and I will see if I can’t get it sorted out and post a solution.

    Exactly … the URL’s look like

    http://www.somewebsite.com/pagename/page/2/

    Hi,

    Please try out the below two steps –

    1. Go to settings -> permalinks and save the settings without making any changes.

    2. If the above step does not fix the issue, then please try adding this filter in your theme’s functions.php file.

    Let me know if it fixes the issue with pagination.

    Regards

    I tried number 1, no luck… tried number 2 and refreshed, no luck… Tried number 1 after number 2, no luck…

    I took a look in Chrome’s developer tools and the 2/ call gets a 301-Moved permanently status if that helps…

    I am also using Zerif-Lite (https://wordpress.org/themes/zerif-lite/) as my theme.

    Any other ideas?

    Also followed the suggestions from Chirag Swadia with no results. Same steps as 00coday … also cleared all cache files.

    One thought… Does the add_filter and following function need to be somewhere specific in the functions.php for the theme? I just put it at the end…

    I think I found the problem… It looks like the pagination works fine when the shortcode is inserted into a post, but not a page. My page http://www.pbdigest.com/test/feed-2 has pagination working properly – “feeds-2” is a post, not a page. My page http://www.pbdigest.com/test/ does not have pagination working…

    I was looking through the code for the plugin and found a lot of $post in the link-template.php file and that’s what made me think to try it as a post. I have seen some chatter that WP 4.4.1 broke some pagination schemes out there and WP-RSS-Aggregator may fall into that category…

    Is there a way to tell the plugin to ignore the permalink settings and always use ?page=x? That seems to work regardless of the permalink setting…

    Found it… The problem is with changes made to WP in 4.4.1. I found the answer at https://core.trac.wordpress.org/ticket/35344

    You need to replace lines 264-270 in wp-includes/canonical.php

    // Post Paging
                    if ( is_singular() && ! is_front_page() && get_query_var('page') ) {
                            if ( !$redirect_url )
                                    $redirect_url = get_permalink( get_queried_object_id() );
                            $redirect_url = trailingslashit( $redirect_url ) . user_trailingslashit( get_query_var( 'page' ), 'single_paged' );
                            $redirect['query'] = remove_query_arg( 'page', $redirect['query'] );
                    }

    with

    // Post Paging
                    if ( is_singular() && get_query_var('page') && ( !is_front_page() || ( isset($wp_query->queried_object) && 'page' == get_option('show_on_front') && $wp_query->queried_object->ID == get_option('page_on_front') ) ) ) {
                                    if ( !$redirect_url )
                                                    $redirect_url = get_permalink( get_queried_object_id() );
                                    $page = get_query_var( 'page' );
                                    if ( is_front_page() ) {
                                                    $redirect_url = trailingslashit( $redirect_url ) . user_trailingslashit( "$wp_rewrite->pagination_base/$page", 'paged' );
                                    } else {
                                                    $redirect_url = trailingslashit( $redirect_url ) . user_trailingslashit( $page, 'single_paged' );
                                    }
                                    $redirect['query'] = remove_query_arg( 'page', $redirect['query'] );
                    }

    I did that

    Have done some more testing on the above solution and it looks like the problem was the WP 4.4.1 build. From what I have read, this will be fixed in 4.4.2, but there is no release date yet…

    Thanks Chirag Swadia for taking a look.

    Hi 00coday,

    I appreciate your efforts in finding this trac ticket https://core.trac.wordpress.org/ticket/35344

    Cheers!

    Thanks for the solution! 🙂

    could someone help me with this code im using extra theme

    same problem as you guys
    the contents in the pagination was always the same

    heres my code:

    <?php $type = strtolower( et_get_option( 'archive_list_style', 'standard' ) ); ?>
    <div class="posts-blog-feed-module <?php echo esc_attr( $type ); ?> post-module et_pb_extra_module module">
    	<div class="paginated_page" <?php echo 'masonry' == $type ? 'data-columns' : ''; ?>>
    	<?php
    	if ( have_posts() ) :
    		while ( have_posts() ) : the_post();
    			$post_format = et_get_post_format();
    			$post_format_class = !empty( $post_format ) ? 'et-format-' . $post_format : '';
    			?>
    				<article id="post-<?php the_ID(); ?>" <?php post_class( 'hentry ' . $post_format_class ); ?>>
    					<div class="header">
    						<?php
    						$thumb_args = array(
    							'size'      => 'extra-image-medium',
    							'img_after' => '<span class="et_pb_extra_overlay"></span>',
    						);
    						require locate_template( 'post-top-content.php' );
    						?>
    					</div>
    					<?php
    					if ( !in_array( $post_format, array( 'quote', 'link' ) ) ) {
    					?>
    					<div class="post-content">
    						<?php $color = extra_get_post_category_color(); ?>
    						<h2 class="post-title"><a>;" href="<?php the_permalink(); ?>"><?php the_title(); ?></a></h2>
    						<div class="post-meta">
    							<p><?php echo extra_display_archive_post_meta(); ?></p>
    						</div>
    						<div class="excerpt">
    							<p><?php
    							if ( has_excerpt() ) {
    								the_excerpt();
    							} else {
    								$excerpt_length = get_post_thumbnail_id() ? '100' : '230';
    								et_truncate_post( $excerpt_length );
    							}
    							?></p>
    							<a>"><?php echo esc_html__( 'Read More', 'extra' ); ?></a>
    						</div>
    					</div>
    					<?php } ?>
    				</article>
    			<?php
    		endwhile;
    	else :
    		?>
    		<article class='nopost'>
    			<h5><?php esc_html_e( 'Sorry, No Posts Found', 'extra' ); ?></h5>
    		</article>
    		<?php
    	endif;
    	?>
    	</div><!-- .paginated_page -->
    
    	<?php global $wp_query; ?>
    
    	<?php if ( $wp_query->max_num_pages > 1 ) { ?>
    	<div class="archive-pagination">
    		<?php echo extra_archive_pagination(); ?>
    	</div>
    	<?php } ?>
    </div><!-- /.posts-blog-feed-module -->
Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Pagination not working depending on permalink setting’ is closed to new replies.