WordPress.org

Support

Support » Plugins and Hacks » Business Directory Plugin » [Resolved] Pagination Not Working

[Resolved] Pagination Not Working

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    Hi geekmenina,

    Please refresh my memory–what precise version of BD do you have right now?

    Previously, any issues with page navigation were cleared up when we added integration with WP-PageNavi. This is the first report we’ve had of it NOT working since, honestly.

    Can we get access to your site? I ask because I just tried this on our test server and it’s working fine.

    Contact me here: http://businessdirectoryplugin.com/contact/

    Hello:

    My version is 3.1.1

    Unfortunately, I cannot give you direct access to the website. If you let me know specifically what you want to access, I could work hand in hand with you to check things.

    Thanks.

    Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    Is this Windows or Linux? That may be a key difference to our usual testing environment.

    If it is, do you have a Windows test server we can use? (not the regular site) We don’t have one (out of our 12 servers we do have).

    I’m not sure why, but my response was deleted. Reposting.

    My server setup:
    Apache/2.2.22 Ubuntu 13.04 (Raring Ringtail)
    PHP 5.4.9-4ubuntu2.3
    mysql Ver 14.14 Distrib 5.5.32, for debian-linux-gnu (x86_64) using readline 6.2

    Is there any other server setup information you need?

    EDIT: disregard my comment about the ratings plugin, I checked the code and saw you were doing an IP address check as well, so I whitelisted certain IPs so that certain users who are indeed different people don’t get blocked.

    Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    OK, so that’s not it.

    Here’s my counter example that shows things are indeed working with BD 3.1.1 and WP-PageNavi, at least in our environment:

    http://businessdirectoryplugin.com/business-directory/page/3/
    http://businessdirectoryplugin.com/business-directory/page/2/
    http://businessdirectoryplugin.com/business-directory/

    Is there any way you can provide us access to a test site that also shows the problem on your side? Something that might be a staging server that has a copy of the production code?

    Our site is also a Linux install, stats here:
    WordPress version 3.6.1
    OS Linux 3.0.18 i686
    PHP version 5.3.2-1ubuntu4.17
    MySQL version 5.5.24-55-log
    SQLite version N/A
    cURL version 7.19.7

    That’s not far off of what you have, so it’s not obvious why you’re seeing this issue, particularly since you tried a plugin/theme conflict check.

    From what I’m seeing, it seems like the WP_Query is getting updated by the paging plugin (I tried to use WP Paginate since it looked like there was support for that plugin as well, same results), but for some reason it is not reflecting on the directory list itself.

    When I print_r() the post query inside the WP Paginate plugin, it shows the next page’s results. I’m not sure why the business directory isn’t reflecting this. I’m assuming it’s a misplaced wp_reset_query(); messing it up.

    EDIT: The pagination is working fine on other pages with categories and posts, like this: http://www.lawwirenews.com/legal-articles/page/2/

    Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    What version of WP are you running?

    Can you provide a test site with this environment outside of your regular site? It’s got some environmental component (otherwise I’d be able to reproduce it on our 12 servers we do have).

    We are running 3.6.1

    I sent you an email through your contact form with access credentials for a testing site with the same setup.

    Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    Got it, we’re looking into it–thanks for the test env!

    Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    Did you get my last email about the .htaccess request?

    Christina

    @geekmenina

    We ended up resolving this issue on our own by coding some changes to the paging and rewrite methods (not within our .htaccess, but the plugin itself, notably in wpbusdirman.php)

    Thank you.

    Plugin Author businessdirectoryplugin

    @businessdirectoryplugin

    Can you tell me a little bit about how you changed it? Since we were unable to reproduce it except on your server, I’m curious what changed. We haven’t had reports of this elsewhere, so if there’s an inherent problem, I’d like to know about it.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Pagination Not Working’ is closed to new replies.
Skip to toolbar