Support » Plugin: Pods - Custom Content Types and Fields » Pagination not working!

  • Resolved senyoraangelica

    (@senyoraangelica)


    I have tried

    <?php
    $params = array( 'orderby' => 'book_year DESC', 'limit' => 5 );
    $pod_books = pods( 'books' );
    echo $pod_books->find( $params )->template( 'book_detail' );
    echo $pod_books->pagination();
    ?>

    and

    [pods name="books" limit="5" orderby="book_year DESC" template="book_detail" pagination="true" ]

    My pods items displays fine but the pagination does not work! I have 50 items on my pod and the first 5 displays fine. The pagination link shows on the bottom but clicking on the link 2, 3, 4, 5, NEXT LAST doesn’t do anything!!!

    clicking 2 is suppose to bring me to /home/books/?pg=2 but it instead goes back to /home/books/

    Please help me. 🙁

    http://wordpress.org/plugins/pods/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    Can you send me the site you’re having an issue with this on?

    scott@pods.io

    Thanks for the reply. I have sent you an email with my site url and a temporary username & password to view the page.

    I would extremely appreciate your help.
    Hoping to hear from you soon,
    Angelica

    Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    Looks like your site is redirecting all queries ?anything=whatever back to the page without it. Do you have other plugins/themes installed that might be doing this?

    No luck. I disabled all my plugins except for Pods and even changed my theme to twenty twelve, but the pagination still doesn’t work. 🙁

    Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    Check your site’s .htaccess file, something is causing this and Pods has never redirected anyone’s site pages like this.

    Can you please please please look at it again? Currently only the Pods plugin and the default wordpress theme is active. But still, pagination doesn’t work.

    I’ve been trying to fix this for weeks now and I’m about to go crazy. 🙁
    I would extremely appreciate your help!

    Edit: I saw your post late. What should I be looking for specifically on my htaccess file? I’m stumped.

    Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    Post your current htaccess file if you can.

    Do you have see a folder or any files in your site files at wp-content/mu-plugins/

    Plugin Author Scott Kingsley Clark

    (@sc0ttkclark)

    In your htaccess file, you have these rules:

    # Remove Extra Query Parameters
    <IfModule mod_rewrite.c>
     RewriteEngine On
     RewriteCond %{QUERY_STRING} !=""
     RewriteCond %{QUERY_STRING} !^p=.*
     RewriteCond %{QUERY_STRING} !^s=.*
     RewriteCond %{REQUEST_URI} !^/wp-admin.*
     RewriteRule ^(.*)$ /$1? [R=301,L]
    </IfModule>

    This is probably what’s causing this issue. Where did these come from?

    Hi, I saved my .htaccess file in text format and sent it to you through your email. I’m sorry but I’m not sure what to look for. I also don’t see a wp-content/mu-plugins/ folder.

    I think that came from a plugin that prevents front end users from viewing my site’s directory. I’m not sure, I’ll check it out.

    Everything is working fine now. Thanks for helping me out!!!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Pagination not working!’ is closed to new replies.