• Resolved kelly99

    (@kelly99)


    Pagination is not working on my main shop page (but works on category pages). I’ve tried deactivation all plugins and have narrowed it down to WC Vendors Marketplace. I even tried switching themes and the only thing that gets pagination to work is deactivating WC Vendors Marketplace.

    Thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jamie

    (@digitalchild)

    Hi @kelly99

    That’s odd! We haven’t had any other reports of this. I can confirm that this is happening on your site. Is this a recent issue or has this always been happening? You are using a theme that overrides large parts of our templates and functions. However you do mention you’ve tried with another theme. Was the other theme you tested storefront? And was the buddyboss marketplace plugin deactivated ?

    It looks like you’re also running our Pro product. If you have an active license you’re entitled to pro support on our website. So please do submit a ticket on our website and we’ll be able to assist further.

    cheers,

    Jamie.

    I deactivated every plugin except for WooCommerce and WC Vendors Marketplace (even Pro was deactivated). Then I tried switching themes to 2017. The only thing that would make Pagination work was deactivating WC Vendor Marketplace.

    I’ve tried updating permalinks settings as well – that didn’t work either. We don’t currently have an active subscription to Pro. It expired in the last 2 weeks, but the last 2 updates before it expired made vendor pages look wonky, so we’re waiting a little to update.

    BTW, we hadn’t noticed it happening before, but we didn’t check either… It was just something we noticed yesterday.

    Please disregard this. I just realized, when the plugin is deactivated, it’s not giving me a 404 error, but pagination is still not working. It’s just showing me the same page over and over. I’m back to the drawing board, but it doesn’t look like it WC Vendors Marketplace.

    Thanks so much for trying to help!

    Plugin Author Jamie

    (@digitalchild)

    Hi @kelly99

    No worries. I would suggest checking your shop pages and make sure they are set correctly. You might need to create a new shop page and assign that in WooCommerce settings. That’ll force the internals to rewrite things again.

    cheers,

    Jamie.

    Yes! You are brilliant! That worked. Thank you so much!

    Plugin Author Jamie

    (@digitalchild)

    Hi @kelly99

    Great to hear! Happy to help. Regarding your previously mentioned issues. We have had a lot of reports from users of that theme of various styling problems. This is due to how that theme implements its template overrides. They override all our templates so when we make structural changes to anything the theme has to be updated. The developer can be very slow to update which is unfortunately out of our control. If you can I’d suggest finding a theme that doesn’t override our templates like they do. You can test things by disabling their marketplace plugin (which is where all their overrides live).

    cheers,

    Jamie.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.