Support » Fixing WordPress » Pagination in Posts Edit Admin Screen Missing

  • Trying to basically apply a Category to all current posts that exist (drafts and private included). However, I noticed the pagination in the console screens right side is not present.

    Did try disabling my plugins to get this working again but it doesnt look like a plugin caused this.

    Any ideas?

Viewing 15 replies - 1 through 15 (of 15 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    – increasing the memory available to PHP?

    As said before, I did already try disabling all plugins to see if the pagination would return. I am already using the default Twenty Ten theme (I will be installing a theme at a much later date) so I know the theme isnt the issue.

    I will try and reset the plugins folder (renaming it to something else and instituting a blank folder named plugins), increasing my memory for PHP and re-uploading a wp-admin/wp-includes.

    Very strange behavior indeed.


    I tried all of the steps that esmi had asked me to try and nothing works. The pages listing still gives me pagination while the posts one does not. :/

    I had a clean install (what I call my sandbox) with simple test data. Just like this site, the sandbox site had the same problem where numbering of pages was given in “edit pages” view but not in “edit posts” view. The version of that sandbox install was 3.0 and even when I upgraded to 3.0.3, it did not solve the problem.

    Another interesting formatting issue is also plaguing the backend of my WordPress interface. It seems that the second column doesnt show up. I have the Screen Options set to 2 columns but the second column settings show up below the first columns, leaving a big white area on the right side where that second column of edit console should be.

    I tried minimizing the dashboard controls (far left) but that does not help. I tried dragging the lower right box in the body editing field to see if I could shrink the width of that first edit column, but it wont let me.

    I suppose I oculd just finish the work Im doing, install anew and hope that it doesnt reproduce the problem on the other side. However, Im wondering if this is a glitch in 3.x

    I’ve just discovered the same issue with pagination.

    The div.tablenav-pages is missing from the HTML completely so it’s not a CSS issue – something has removed the entire DIV.

    I’ve been investigating… here’s what I’ve found:

    The div.tablenav_pages is written out on lines 388-400 of /wp-admin/edit.php:

    <?php if ( $page_links ) { ?>
    <div class="tablenav-pages"><?php
    	$count_posts = $post_type_object->hierarchical ? $wp_query->post_count : $wp_query->found_posts;
    	$page_links_text = sprintf( '<span class="displaying-num">' . __( 'Displaying %s–%s of %s' ) . '</span>%s',
    						number_format_i18n( ( $pagenum - 1 ) * $per_page + 1 ),
    						number_format_i18n( min( $pagenum * $per_page, $count_posts ) ),
    						number_format_i18n( $count_posts ),
    	echo $page_links_text;

    $page_links is defined in lines 311-318:

    $page_links = paginate_links( array(
    	'base' => add_query_arg( 'paged', '%#%' ),
    	'format' => '',
    	'prev_text' => __('&laquo;'),
    	'next_text' => __('&raquo;'),
    	'total' => $num_pages,
    	'current' => $pagenum

    I added the following after 318 to see what was in $page_links:

    echo "<!-- ";
    echo " -->";

    The output, as expected, was a blank array.

    I changed $page_links to:
    $page_links = paginate_links();

    to see if the default values for paginate_links (line 1943 of /wp-includes/general-template.php) worked.

    Again, a blank array.

    So paginate_links is returning a blank array – but I can’t figure out why that would be.


    Has anyone come up with a solution to this problem? It is really dogging me — I am using WordPress for class in which 50+ students are producing content for a single blog, and I can’t get to their draft content.

    I since upgraded to the latest version and converted to a Multisite and I don’t have this problem anymore.

    If you’re using v3.2.1 and still having this issue I’m afraid I still don’t have an answer :-/


    Shoot. I upgraded to 3.2.1 and the problem did not go away. It is a site wide problem, and affects sites even if all plugins are disabled. Looking at the mu and drop-ins, I have the following:


    • Blogs Directory, Version 1.0.7
    • Default Theme, Version 1.0.0
    • More Privacy Options WP3.0, Version
    • shibboleth-mu.php
    • Simpler iPaper, Version 1.3.1
    • WordPress MU Domain Mapping, Version 0.5.4


    • object-cache.php APC Object Cache Version 2.0.2
    • sunrise.php

    To clarify the previous comment — it affects a site even if that site’s plugins are all disabled. I cannot disable the mu and drop-in plugins, though, on the production server, so I list them here just in case someone notices something about them. (Of course, I ought to disable them on our test server to see what happens.)

    I’m chasing the same mess over here (It’s not related to W3 TC but I had some other stuff going on too) ->



    I have fixed this problem!
    (actually my hoster provider did)

    The fix:

    Disable mysql.trace_mode in php.ini



    Hey — that worked! Thanks. Sure scratches an itch, and just in time for Thanksgiving break.



    I appreciate the followup by Fylh. That is the same conclusion we finally arrived at at approximately the same time.

    Unlike you disabling it from the php.ini we disabled it at the server level as it was not needed for other processes on that dedicated/VM.

    I’m uncertain if we prior enabled this for debugging purposes or if it was a artifact of an older version of php. Because I acquired the issue near the 3.0 beta, I assume it is somehow linked to the change over in php requirements that happened in that same time-window.

    We arrived at this by looking at the code philpeter submitted and realizing within the query was a non-standard mysql query. This non standard query has some issues with that particular php tool and freaks out. Oddly if you replace it with the native mysql command it doesn’t freak out… but that involves altering core code so was not really an option for me.

    Disabling that command completely restored the pagination issue.

    Thank you for everyone that assisted publicly and privately in helping debug this. It was a heck of a mess LOL!




Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Pagination in Posts Edit Admin Screen Missing’ is closed to new replies.