WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Pagination doesn't display

[Resolved] Pagination doesn't display

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jose Luis SAYAGO

    @iluminatus

    Hi, thanks for your comment. Could you please tell me the parameters you’re using in the shortcode?

    For pagination to work two parameters must be specified:

    1. paginate=true
    2. posts_per_page=x

    Where x is the number of posts you want to be displayed.

    Something like:

    [slposts thumbnail=true
             paginate=true
             posts_per_page=3
    ]

    Best regards.

    Hi, this is a paste of the code I’m using:

    [slposts thumbnail=true thumbnail_class=thumb wrapper_list_css=tei-blog thumbnail_wh=80x80 paginate=true posts_per_page=10]

    So that should work..

    Plugin Author Jose Luis SAYAGO

    @iluminatus

    Hello, well there is a parameter I didn’t take into account the first time: number_posts which is 10 by default. If you leave it alone, even if you paginate posts, it will always limit the number of posts to 10.

    Please try to set a high number there so it doesn’t interfere with your pagination, something like:

    [slposts thumbnail=true
           thumbnail_class=thumb
           wrapper_list_css=tei-blog
           thumbnail_wh=80x80
           paginate=true
           posts_per_page=10
           number_posts=1000
    ]

    Best regards.

    That explains it! Thanks.

    Perhaps that should be added in by default.

    Plugin Author Jose Luis SAYAGO

    @iluminatus

    I will keep it in mind for future releases, glad it worked.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Pagination doesn't display’ is closed to new replies.