Support » Plugin: qTranslate X » Pagination does not work if Query Mode used

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author John Clause

    (@johnclause)

    Hi @vaneo, please give me steps to reproduce the problem. Do I have to write a code? If so, give me the code and where to paste it under standard WP with the only q-X as you mentioned.

    Hi John, thank you for your answer. Just put next_posts_link and previous_posts_link calls in your index.php template, for example, here is mine:

    <div id="primary">
    
    	<?php if ( have_posts() ) : ?>
    
    		<?php /* Start the Loop */ ?>
    		<?php while ( have_posts() ) : the_post(); ?>
    
    			<?php get_template_part( 'content', get_post_format() ); ?>
    
    		<?php endwhile; ?>
    
    		<?php next_posts_link('Older Entries') ?>
    		<?php previous_posts_link('Newer Entries') ?>
    
    	<?php endif; ?>
    
    </div><!-- #primary -->

    Regards,

    Plugin Author Gunu

    (@grafcom)

    @vaneo,

    have you also tried it with the standard WP theme twentythirteen without any adjustments?

    Edit:

    Permalink Setting which I can’t change.

    Why you can not change this?

    Plugin Author John Clause

    (@johnclause)

    @vaneo: could you try the latest q-X available from GitHub?

    The test version can be downloaded from GitHub page with button “Download ZIP”, or click here for the sake of convenience.

    @gunu,
    Hi, I have just tried it with clean Twenty Thirteen theme without any adjustments and I can still reproduce the issue.

    @johnclause,
    Thank you very much, you solved my problem!
    New test version I have downloaded from GitHub works! 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Pagination does not work if Query Mode used’ is closed to new replies.