Support » Plugin: TablePress » Pagination Disappeared/Reset

  • Resolved SBI23


    When I initially set up a table with 30 rows and 2 columns, it displayed properly. After a couple hours of messing around with other stuff, I noticed that the pagination had disappeared. It no longer shows 10 items at a time like I had set it up to. It now shows all the items at once in a long table.

    I checked the “Features of the DataTables JavaScript Library” and the checkbox for pagination is still checked and set at 10 rows per page. The Table Press plugin is the most recent plugin I activated so I know that it can’t be another plugin that disrupted it, since it was initially working correctly.

    Any thoughts on what I can do to fix this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author TobiasBg



    thanks for your post, and sorry for the trouble.

    There’s probably a conflict happening somewhere, or a typo that breaks the HTML code of the table. Please post a link to the page with the table with the broken pagination, so that I can take a direct look. Thanks!


    While testing, I changed the theme back to an old one and it seems that the table displayed correctly. But when I changed my theme back to my current one, it was not displaying correctly anymore. Which leads me to believe that the theme is interrupting the table somehow. I then tried tweaking any theme specific options, but still cannot figure it out.

    Well, I just figured it out. I had a newsticker widget on my sidebar and apparently that was stopping it. As soon as I removed that, the tables began displaying correctly.

    Thanks for a quick reply and helping anyways!

    Great support!

    Plugin Author TobiasBg



    ah, nice catch! That probably means that that sidebar widget added some JavaScript code that breaks the rest of the JS.
    Good to hear that removing it fixed it!

    Best wishes,

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Pagination Disappeared/Reset’ is closed to new replies.