WordPress.org

Support

Support » Plugins and Hacks » The Events Calendar » [Resolved] Pages/Posts not displaying when The Events Calendar is deactivated

[Resolved] Pages/Posts not displaying when The Events Calendar is deactivated

  • Using WPMS, version 3.5.1 and the latest version of TEC at the time of writing. As it stands, if TEC is deactivated on any of my sites, the edit posts/pages interface shows only a single page or post.

    With the plugin activated, the issue goes away and the site works as expected.

    The site lists the correct number of published, draft, trashed posts/pages but shows only one in the edit interface.

    Removing TEC does not fix the problem.

    Why would it cause this issue? How can I fix it?

    http://wordpress.org/extend/plugins/the-events-calendar/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi John,

    Sorry to hear about this. I have no idea why this would be happening. Would you be willing to test out our 3.0 beta to see if this is resolved? If so, please email pro [at] tri [dot] be attn. to me and reference this thread.

    Thanks,
    Jonah

    Hi Jonah,

    I don’t think trying a new version will help. The problem manifests itself when the plugin is deactivated/removed and while we want to use TEC on some sites, we are also using WPML which as you’re probably aware is incompatible with TEC.

    As such, we need to remove/deactivate it on some/all sites unless the 3.0 beta has been made to work with WPML?

    Ok, situation also manifests itself on my local machine (Ubuntu VM) as well as the remote system (Redhat VM).

    Problem is related to WP SEO, when TEC and Yoast’s WordPress SEO plugin are deactivated the problem goes away.

    I’d added a filter to load a custom meta title on my events pages. When the events calendar was deactivated, the filter was running but was causing issues with the presentation of content.

    By commenting-out the filter

    add_filter('wpseo_title','events_calendar_titles');

    The problem went away. That said, I still want to display custom meta titles on my events pages so I need to wrap the filter in an if statement that checks to see if TEC is active.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Pages/Posts not displaying when The Events Calendar is deactivated’ is closed to new replies.
Skip to toolbar