Support » Requests and Feedback » PageSpeed SEO score 92 (Accordion titles not crawlable)

  • Hi there!

    PageSpeed shows score of 92 on SEO which is pretty good. However, the report shows that FAQ accordion titles are not crawlable (I have 5 of them)

    Can’t see anyway to put anchor links or put some hrefs?

    Does anyone know how to make the accordion titles crawlable?

    Cheers!

    • This topic was modified 1 month, 1 week ago by kennyflo.
Viewing 12 replies - 1 through 12 (of 12 total)
  • What did you use to create these “FAQ accordions”? WordPress doesn’t have any accordion block/feature by default. Is this from your theme? Or a plugin? And what’s the URL in question so I can take a look?

    Thread Starter kennyflo

    (@kennyflo)

    https://propercleanaus.com.au/service/office-cleaning

    Hi using elementor. Theme is case theme core. If you scroll down the page you will see the 5 accordion. Thank you

    Thanks for the link.

    The accordions user anchor <a> tags without an href attribute. And that’s perfectly fine by the HTML technical standard:

    The href attribute on a and area elements is not required; when those elements do not have href attributes they do not create hyperlinks.

    Whatever tool you’re using is saying the FAQ titles are not crawlable. And that’s because there are no links to crawl. Which makes perfect sense, and there’s no problem here to solve.

    I’ll ignore this “report”.

    Thread Starter kennyflo

    (@kennyflo)

    Links are not crawlable
    -Search engines may use href attributes on links to crawl websites. Ensure that the href attribute of anchor elements links to an appropriate destination, so more pages of the site can be discovered. 

    Hi thanks for the reply. This is what google pagespeed is stating?

    Links are not crawlable

    Because there are no links. Links cannot be crawlable when there are no links, to begin with. And you’re not required to have links if you don’t need links.

    I’ve pretty much explained this above.

    If you want to have crawlable links just to satisfy the tool (when there’s absolutely no need to), then don’t use accordions. Instead, create anchor links to different locations on the same page.

    If you’re not OK with this explanation, then I’ll kindly recommend that you ask the authors of the tool you used to create the FAQ accordions for help.

    You’re using Elementor PRO, and commercial plugins are not supported here.

    Please login to your Elementor.com account and open a support ticket with the folks that made the plugin you’re using to create these FAQ accordions. They built the feature, and they can best assist you.

    Good luck!

    Thread Starter kennyflo

    (@kennyflo)

    I see! There were no links cause it’s not even supposed to be a link to begin with. That’s what i’m trying to get into. Perhpas google made a mistake in thinking it’s a link!

    I’ll go to elementor. Thanks!

    This similar post and the response from Elementor plugin’s support staff might be of interest: https://wordpress.org/support/topic/links-are-not-crawlable-in-google-pagespeed-insight/

    Thread Starter kennyflo

    (@kennyflo)

    I went to Elementor community page as you suggested but it’s a FB group and nobody has responded yet (Not so helpful Elementor!)

    It’s either Google is incorrectly reading the accordion as links (when it’s not supposed to be) or Elementor has not developed it correctly to Google’s reading.

    I went to the link you just posted and can see Elementor stopped responding.

    I went to Elementor community page as you suggested

    I didn’t suggest that 😀

    I asked you to open a ticket from your Elementor.com account. That’s an internal help desk system for PRO users only, and is totally different from the community forum on Facebook which is open to everyone.

    Thread Starter kennyflo

    (@kennyflo)

    LOL whoops! Oh no. I’m not using the pro version. SO frustrating

    I’m not using the pro version.

    Sure, you are.

    Why would I just assume so… if I didn’t have any evidence to think so?

    Thread Starter kennyflo

    (@kennyflo)

    Hmmm really? It can’t be. Thought i’m on the free version. Don’t think i ever paid for the pro

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.