Support » Plugin: Autoptimize » pagespeed mobile says js not concat

  • Resolved ionian

    (@ionian)


    Hi,
    When I use googles pagespeed it gives me a really low score on the mobile.
    In the rendering section it says there are 24 js blocking files however in the desktop it says there is only one (jquery.js).

    I have checked the “optimize js code” .

    Can this be right for them to be render blocking for mobile and not desktop?

    I can see in another thread on here there are some problems with Cflare/Autoptimize.
    Could this be related?

    Thanks for any help you can give. Appreciated.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    I can only help if I can *see* what is happening I’m afraid @ionian, so I would need your site’s URL. Can you provide that?

    Hi thanks for the reply and sorry I didn’t add it first.

    http://www.propertyinvestmentsuk.co.uk

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    given that you have a responsive website, where the exact same HTML is used to render both the desktop and mobile version of your page, one would indeed expect the “render blocking JS” list for mobile & desktop to be more or less the same. the fact that there are no render blocking JS-files on desktop seems wrong, as your HTML does contain a significant amount of JS-files that are not optimized. Can you share your AO JS optimization settings?

    What’s the best way to do that? A couple of screen shots?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    And did you install and configure AO @ionian? I’m seeing some unexpected things when looking at the HTML source which are not in line with your configuration?

    Yes I did.
    We use cloudflare so I am thinking there is some conflict there.
    What are you seeing that is out of place?
    Are you seeing CSS and js file where they shouldn’t be?

    Any idea about fixing this?
    Would deleting the plugin and starting again be any use?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    What are you seeing that is out of place?

    I’m seeing a lot of JS-files that indeed are not aggregated/ optimized and I see that the Autoptimized JS is not inserted at the end of the HTML.

    Any idea about fixing this?

    As this is probably due to a theme of plugin conflict, the best way forward would be to selectively disable (and re-enable) plugins and/ or to briefly switch themes to find out what is causing this erratic behavior.

    OK, thanks for that I will give it a try.

    Turned out it was the SEO Prosser plugin that was causing the problem. It had been working for months before that.

    Thanks again for the support.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    @ionian; that’s https://seopressor.com/ right? did they push an upgrade? did you contact their support?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘pagespeed mobile says js not concat’ is closed to new replies.