Support » Plugin: Imagify – WebP & Image Compression and Optimization » Pagespeed Insights Still Says Images are not being Served in WebP

  • Resolved rscarter1

    (@rscarter1)


    I used your plugin, bought a one-time package, optimized all images, and actived the WebP setting on the settings page. I deleted the cache and checked PageSpeed Insights again but there is no change. Still says images are not being served in WebP.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author WP Media

    (@wp_media)

    Hello @rscarter1

    Thanks a lot for your patience!

    Just to be sure, it looks like you have deactivated WebP delivery via Imagify. Or the current behavior is the one with activated setting?

    Best Regards

    I had to deactivate the plugin, yes. Some images weren’t showing at all, we didn’t know why. But when I deactivated the plugin, the images appeared. Weirdness. I must have had some setting wrong but I tried a bunch. Not sure.

    Plugin Author WP Media

    (@wp_media)

    Hello @rscarter1

    Thanks for letting me know.

    This kind of issues happened to a few other users as well. In all of these cases, the problem was with WebP. I believe you use <picture> tag for displaying these, right?

    If you don’t use CDN (except Cloudflare), can you try to use Rewrite rules for displaying WebP and test how it works?

    It should be more stable in terms of affecting the code of your pages.

    Best Regards

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.