Support » Plugin: PageSpeed Ninja » Pagespeed insights broken when using optimization of “optimal” or above

  • I use ngrok while developing locally to share my wordpress sites with other. In order to do so, I have to use a plugin called “relative-urls’ which, as the name states, makes the link structure relative instead of absolute. I say this because I believe it may be causing the interference.

    When I set Pagespeed Ninja to a setting of “Optimal” or higher, Google Pagespeed Insights gives me the following message.

    Lighthouse returned error: ERRORED_DOCUMENT_REQUEST. Lighthouse was unable to reliably load the page you requested. Make sure you are testing the correct URL and that the server is properly responding to all requests. (Status code: 500) You may refresh to try again.

    The Ngrok logs show the process GET / returning the 500 Internal Server error code upon any use of the sight. Oddly enough, the site loads just fine.

    I tried to solve the issue by finding the differences between the “Compact” and “Optimal” settings, but failed to tease out any meaningful pattern.

    UPDATE: I’ve teased out the option “Prioritize visible content” to be the issue. I have no clue as to why it’s causing this error, however. Any ideas?

    Thanks!

    • This topic was modified 1 year, 8 months ago by michaelslec.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Denis Ryabov

    (@dryabov)

    Currently I don’t have ideas, but I’ll try to test PageSpeed Ninja with the relative-url plugin, hope it will allow to localize and fix the issue.

    it happens when you use “Use libxml HTML parser” option

    Confirmed, in “Advanced” Setting you must select “Use Standard Full HTML parser” to avoid this issue. I just did it in a client’s website, and everything works now with the test speed. Thank’s to donbebeno for his message 🙂

    see
    https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Fhome-tov.com%2F
    I also face the problem! where i get the option? Oliver de la Rosa

    @oliverdelarosa I face Lighthouse returned error: FAILED_DOCUMENT_REQUEST. Lighthouse was unable to reliably load the page you requested. Make sure you are testing the correct URL and that the server is properly responding to all requests. (Details: net::ERR_CONNECTION_FAILED)
    Where I get the messege?

    How can i solve this issue ? I also face the problem in Lighthouse

    Lighthouse returned error: FAILED_DOCUMENT_REQUEST. Lighthouse was unable to reliably load the page you requested. Make sure you are testing the correct URL and that the server is properly responding to all requests. (Details: net::ERR_TIMED_OUT)

    I just change to new server. after that I’m facing this problem.

    overlord08

    (@overlord08)

    Goto jetpack settings > Turn off brute force attack protection !

    meetmehra.com – I write about Digital Marketing and Making money online!

    thogarrai

    (@thogarrai)

    my case blocked all countries except home country,

    google pagespeed used nearest test location.

    after disabling it worked (Status code: 403

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.