WordPress.org

Forums

Pages won't work (18 posts)

  1. shadow
    Member
    Posted 10 years ago #

    I have just noticed that when I try to make page it will not work.

    Any attempt pumps out a message like this when I try to view the page...

    Not Found
    The requested URL /pagename/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Any ideas?

  2. oriecat
    Member
    Posted 10 years ago #

    What if you update your permalinks structure?

  3. shadow
    Member
    Posted 10 years ago #

    @oriecat
    Just tried and no go.

    It's weird because 3 pages I already had setup are working, but any new ones give me the error message.

  4. shadow
    Member
    Posted 10 years ago #

    I have tried a few things here but still having this same problem.

    I read through http://wordpress.org/support/topic.php?id=24402 which is very helpful but I am beginning to think I should turn off permalinks.

    Can anyone tell me the advantages or disadvantages of this action?

    I realise that some links from other site to me will be lost but is this the only problem and will it solve my problem with creating pages etc?

  5. moshu
    Member
    Posted 10 years ago #

    Is your .htaccess file writeable?

  6. Jinsan
    Member
    Posted 10 years ago #

    Shadow, clear your .htaccess and set your .htaccess to 644 and then update the permalink structure. you need to have your htaccess writable for pages as it makes it easier than copying and pasting (where you may end up adding extra spaces).

  7. shadow
    Member
    Posted 10 years ago #

    Ok cleared out my .htaccess and then made sure it was set to 644 [which it was]

    Now I cannot access anything but the front page ..Any attempt to go to a post or a page leads me to Not Found
    The requested URL /pagename was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

  8. shadow
    Member
    Posted 10 years ago #

    Is there any way of setting a stable .htaccess ?

    And this is why I am thinking I should return to no permalinks. I never had these problem previously.

  9. moshu
    Member
    Posted 10 years ago #

    Ok cleared out my .htaccess and then made sure it was set to 644 ...

    ...and then you updated your permalink structure, didn't you?

  10. shadow
    Member
    Posted 10 years ago #

    Yes of course:)

    All set as

    /%year%/%monthnum%/%day%/%postname%/

  11. Jinsan
    Member
    Posted 10 years ago #

    can you get into the admin side, your http://domain.com/wp-admin

    Delete the .htaccess file entirely and you should be able to access your site. You may then want to create an empty notepad file, rename it .htaccess upload it to the root of your instal and then update the link structure while you are in the admin area. Create a new page and if it comes down to it, set your .htaccess to 777 just to see if it will write the page to the htaccess file.

    Then set the htaccess back to 644 and see you can view your site and view the pages.

    I've not had an issue with htaccess myself, with some exceptions, but nothing that would cause my site to start pumping out 404 errors. There are some weird things that do happen, and sometimes it can be host related in that you have to set your htaccess higher then recommended in order for it to work on certain hosts

  12. shadow
    Member
    Posted 10 years ago #

    Ok set it to 777 and tried to reload pages in site. Same.
    So looked at new .htaccess
    Nothing written in there even when set at 777 and same when tried to write a new page.

    I can still get to admin and to the index.php of site but nowhere else.

  13. Jinsan
    Member
    Posted 10 years ago #

    so it's not even writing....that is very odd. Perhaps it's host releated? Maybe they don't support htaccess? Though it would be a bit odd...but you never know.

    Hopefully someone can provide a more robust answer, meanwhile dump the htaccess file and stick to your standard structure. You can of course use the non-htaccess method of constructing permalinks. If you check the codex for permalinks it offers a second way which is to place index.php before the structure you want so:

    index.php/thepermalinkstructure/ and it will display as yourdomain/index.php/structure

    Did you use the default permalink structure or something else?

  14. shadow
    Member
    Posted 10 years ago #

    Any time I have trouble like this, I have kept a backup of an old .htaccess file from when I was on another server. I upload that and things work - well partially anyway, I can access pages etc but still cannot write pages.

    If I turn off permalinks will this all be resolved?

  15. shadow
    Member
    Posted 10 years ago #

    I use this structure

    /%year%/%monthnum%/%day%/%postname%/

  16. Jinsan
    Member
    Posted 10 years ago #

    Assuming you can't write to the htaccess file, and you have copied and pasted each time to the end of the htaccess file then I'm at a loss.

    If you turn off permalinks, well yeah it might be resolved - only one way to check, becuase you can't seem to directly write to the htaccess file so you won't known until you give it a go. You could always turn it back on anyway.

    Here's an example of structure without the htaccess file. This is using the index.php

    http://fredfred.net/skriker/index.php/polyglot

    note the index.php - that might possibly work for you, but I don't think it works if you have a htaccess file -an empty htaccess file will simply stop you from viewing your site

  17. Jinsan
    Member
    Posted 10 years ago #

  18. shadow
    Member
    Posted 10 years ago #

    Will read now.

    I have just addeed the index.php option and it seems to be working
    /index.php/%year%/%monthnum%/%day%/%postname%/

    So does this all mean my webhost is not allowing .htaccess?

    Thanks for all the help. It all seems to be running smoothly now. I guess the only downside is that anyone who had links to my permalinks will now end up at a 404.

    Still, I can get in touch with those 2 people and tell them to change it :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.