WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Pages won't update. Get "bad request" error.

[Resolved] Pages won't update. Get "bad request" error.

  • All of a sudden (I think after upgrading to wp 3.5) I’m unable to “Update” certain (not all) pages on my website. Instead, I get the following error message (on Firefox browser):
    “Bad Request
    Your browser sent a request that this server could not understand.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

    I’ve tried changing the Permalink options, but that does not change anything. The only thing that does work is if I delete the Page and then re-create it.

    I’ve checked the other Forum postings on similar “Bad Request” problems, but none have a solution. Can anyone help?

Viewing 3 replies - 1 through 3 (of 3 total)
  • WPyogi

    @wpyogi

    Forum Moderator

    If you recently upgraded, start troubleshooting by going through the suggested steps in this thread:

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    Good Work on the document, Mika. And thanks for the prompt reply. After going through your troubleshooting document, I didn’t see my issue being addressed. (I did, however, visit the known pages of this issue in the Forum without locating a solution.)
    Maybe there’s other experiencing this problem?

    Help still needed. Thanks in advance…

    After some extensive research, I found that the problem was due to my web hosting server’s ModSecurity firewall in Apache module. It appears that WP 3.5 is a bit too sensitive with security. Anyway, all I had to do was to contact my hosting service and they went into the account and made the adjustment.

    Hope this helps others that are experiencing this problem. (BTW, if you’re having problems with your hosting service, I recommend Westhost.com.)

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Pages won't update. Get "bad request" error.’ is closed to new replies.
Skip to toolbar