Support » Fixing WordPress » Pages with only #’s in permalink not working right

  • Hey,

    Just upgraded to 2.5 and it was very smooth…however I just noticed a problem. I have a page called Photo Gallery at /wordpress/photo-gallery/ with several sub pages where I have my photos separated by year, ie. /wordpress/photo-gallery/2005/, /wordpress/photo-gallery/2006/, etc. However my subpages that have only #’s in the permalink don’t show–they show the immediate parent page instead. But, if I navigate to /wordpress/photo-gallery/2005/2005/ I can get to the page, even though that’s not the correct permalink.

    This only happens for pages that are all #’s. Pages that start with numbers but have other characters in them work fine. I’m not sure if this is a bug or something got whacked on my .htaccess or what. Any ideas? I’ll install a fresh version of 2.5 and see if I can replicate it.

    BTW, I’m using NextGen Gallery as my photo gallery, but had the same issues when I created a blank page and titled it “1234.” You can check out the phenomenon here. Thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • So I did try it on a fresh install and am having the same problem there. It appears to be some sort of bug I guess. When permalinks are turned off you can get to the page by using ?page_id=4, but once permalinks are turned on I either get a 404 if the page is a parent or I get the parent page if it is a child.

    I just went to your site and all the links seem to be working fine… am I missing something?

    Ps. I clicked on every page link (Our wedding, 2005 photos, 2006 photos, 2007, photos… etc) at the link you gave me

    Ok, I found out how to get the screw up… when I click on the permalink at the top of a given page (like “2005”) it’s linking to /photo-gallery/2005 instead of what the links on the main page were pointing to (/photo-gallery/2005/2005). Did you “fix” it by simply adding a page child to 2005 called 2005, and link to that instead?

    Basically, I’m as stumped as you are.

    Stevish,

    Yes, sorry I “fixed” the link structure on that page. (We’re expecting a baby any day now, so we’ve got lots of family and friends waiting for more pictures). However, all of those pages have the permalink structure of “/photo-gallery/2005/” as you indicated when clicking on the title of the page. I tested it on a fresh 2.5 install and received the same results. Do you have 2.5 running anywhere? If so, are you able to reproduce the problem? Thanks for looking into it.

    Yeah, I can try… what’s your permalink structure?

    Day and Name: /%year%/%monthnum%/%day%/%postname%/ Thanks

    Yep… mine does the same thing. Not sure how to fix it exactly…

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    WordPress 2.5 just does not like numeric slugs. The new rewrite system can’t cope with it. Sorry, there’s no patch yet.

    Change them from 2005 to something that has an alpha in it. Like year2005 or something.

    hmm…that’s unfortunate. I’ll have to go back and change a bunch of links in posts and that as well. I may just leave it with /2005/2005/ links for now until a patch is made…is a patch planned?

    oh my dear Otto42
    ….

    /%year%/%monthnum%/%day%/%postname%/

    was the default permalink structure for a very long time in WP…

    after a few months ago some plugin haven’t work if you have another permalink structure than the above…

    at Austria we call something like this ‘Ver-schlimm-besserung’..

    ‘change for the -get worse- better’

    😉

    broken permalink and broken mediathek

    and no Info about :do not use duplicate category names…

    kindly regards Monika …..:-)

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    /%year%/%monthnum%/%day%/%postname%/

    was the default permalink structure for a very long time in WP…

    Still is, last I checked.

    I didn’t say that that was wrong. What I said was that all-numeric postnames cause problems.

    WOW – this one was killing me!!! thanks for sorting it out so I could reap the benefits!

    best,
    shua

    I have the same problem but I name certain pages after the numeric title of an art piece.
    Go here: http://eagleapex.com/digital-prints/
    “18”, “1113”, and “3119” all suffer from missing pages.
    Also http://eagleapex.com/digital-prints/12/ which is a test page I made that worked fine without a parent. I’m not using a date-based permalink structure, so what re my options?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Pages with only #’s in permalink not working right’ is closed to new replies.