WordPress.org

Forums

[resolved] Pages take 30 seconds to load; MySQL "sleeps" (9 posts)

  1. eugenekogan
    Member
    Posted 8 years ago #

    I'm running WP 2.1, PHP 4.3.11, and MySQL 4.0.27, hosted on GoDaddy.

    My site was running fine for the first week. I have about 20 posts, maybe 10 categories, and just a few comments. There is nothing multimedia intensive that would cause the site to load slowly. The bandwidth to the server is fine, since I can FTP large files without issue.

    For some reason, WP has become incredibly slow today, for no obvious reason. Every page, including admin pages, take between 15 and 30 seconds to load. I've tried going back to the default theme, deactivating all plugins, and playing with the options. Nothing has made a difference.

    Now, I was looking at MySQL processes while trying to load a page. I noticed several "sleep" commands in the current SQL process list. Some of these sleep commands stay there for up to 6 seconds. Are these normal, or is something wrong? The database is so small, there is no reason for any of the queries to take more than a second.

    Does anyone know what the problem might be? ANY ideas would be very much appreciated...

  2. vkaryl
    Member
    Posted 8 years ago #

    Have you tried deleting all the stuff in the "notify these sites" field in Options/Writing/Update services? Or whatever/wherever it is these days....

  3. eugenekogan
    Member
    Posted 8 years ago #

    Good idea... I tried that, but it didn't help. Also, I don't think that would affect the admin pages, which are just as slow.

  4. eugenekogan
    Member
    Posted 8 years ago #

    No one knows if the MySQL "sleep" commands are normal?

  5. vkaryl
    Member
    Posted 8 years ago #

    I've never seen anything like that.... since I've got upwards of 30 installs, plus numerous other mysql databases other than wp, I'd think I'd have seen it at some point or the other, but truthfully I've never run across it.

  6. eugenekogan
    Member
    Posted 8 years ago #

    Problem solved by moving to A Small Orange. Wow, this is so much faster than GoDaddy every was, and the interface is a lot better, too. Feel free to use me as a referrer :)

    http://www.asmallorange.com/services/hosting/?refer=eugk

  7. vkaryl
    Member
    Posted 8 years ago #

    Ah. Well, thanks for letting us know!

  8. SteveFree
    Member
    Posted 7 years ago #

    This issue needs to be re-opened. It's not resolved. I'm having the same issues. Admin pages are taking 30 seconds to load and when I look at my mySQL server, the query is sleeping for 30 seconds before it executes. Why is this?

  9. Gasper
    Member
    Posted 7 years ago #

    Having the same problem myself.

    I'm on dual xeon 2.8 2 gig of ram
    apache 1.3.9 and php 4.4.7

    There are mysql "sleeps" for 60 seconds on
    many of my blogs. (some work though!!???).

    I'm trying to solve the problem for 2 weeks. Will keep you updated if I solve it.

Topic Closed

This topic has been closed to new replies.

About this Topic