Support » Plugin: WooCommerce » Pages Shortcodes not working after update to 2.1.2

Viewing 15 replies - 1 through 15 (of 26 total)
  • I have the exact same issue. I upgraded to 2.1.2

    and now instead of the Edit My Address page I just get a shortcode displayed:

    [woocommerce_edit_address]

    @bijay

    I found this article

    WooCommerce 2.1.X Endpoints vs Shortcodes

    I still don’t understand the problem!!

    thanks Lord,

    I too found that no full reference though. I permanently removed those pages and setup the custom links still it does not work. I too dont understand the problem either.

    @bijay

    I posted a question here

    WooCommerce 2.1.X Endpoints vs Shortcodes

    The man who runs that website is a WooCommerce developer. Hopefully he will reply to my question.

    Maybe you could post a question too? If you did it might make him respond.

    Thanks

    @bijay

    I have uninstalled 2.1.2 and regressed to 2.0.20 I don’t have the time to spend on this, if you get an answer please let me know.

    Cheers

    Plugin Author Mike Jolley

    (@mikejolley)

    Hi guys,

    Your issue is that you are expecting shortcodes to function which no longer exist. On new installs, these pages won’t be created, but if you are updating you may already have those pages in place.

    Although the upgrade script does attempt to trash them for you, this might not have happened if they were customised. Delete them. Delete edit-account and change password, then go to your ‘my account’ page and click the change password/edit account links. You’ll be taken to and endpoint which offers the same functionality.

    Thanks

    Plugin Author Mike Jolley

    (@mikejolley)

    I’ve wrote a little doc on the subject here http://docs.woothemes.com/document/woocommerce-endpoints-2-1/

    Hey Mike,

    I read your “little” documentation on the endpoints and implemented it by adding a link to the menu, but the page didn’t appear at all. For instance, I added the link that has the caption “View Order” and when I clicked on the link, it showed the ‘My Account’ page, not the “View Order” page as I expected it to.

    Plugin Author Mike Jolley

    (@mikejolley)

    What URL did you give the page?

    I followed the instruction provided in the documentation by using the full URL. For instance, the URL in the link is: http://(mysite).com/my-account/view-order/

    For obvious reasons, I am not disclosing the name of the site.

    Plugin Author Mike Jolley

    (@mikejolley)

    /my-account/view-order isn’t going to be directly accessible because you’ve not specified an order to view. It doesn’t need to be in your navigation menu and shouldn’t be.

    Go to My Account, look at the orders, click ‘view’: https://dl.dropboxusercontent.com/s/gylskujq18j5rjb/2014-02-26%20at%2022.31%20%281%29.png

    The URL will be something like /my-account/view-order/9239/ and THAT will work.

    Ah I see! Then you should make the documentation a little bit clearer on that. Thanks.

    bijayyadav

    (@bijayyadav)

    Solved the issue. Thanks !!!!

    hi following up on this, there seems to be an issue within the my-account short codes, unless I am missing it

    on the my-account page as per instructions from above we see a page with the following text

    “Hello, xxxx. From your account dashboard you can view your recent orders, manage your shipping and billing addresses and change your password.”

    the change your password appears to be a woo built in link which should go to the correct page, however it takes you around in a loop on my-account page.

    So following all the great help you posted above and using the relevant shortcode for the account page [woocommerce_my_account] this page does not work as you would expect

    so what am I missing from above ?

    thanks

    I have the same problem as Scruffy above. A loop with the my-account page. I have tested with a new wordpress and woocommerce install, same issue. Only workaround I have found is to turn off permalinks, and that’s not ideal.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Pages Shortcodes not working after update to 2.1.2’ is closed to new replies.