Support » Fixing WordPress » Pages Not Working wp1.5

  • Ok… Let me start out saying WordPress RockS! Second of all… I have a problem with the pages. Someone has tried to help me, but I’m still lost. Whenever I create a page, it creates the link on the main page but then when I click it, it goes back to the main page, like I created a duplicate. I was told this has something to do with htaccess file and my chmod settings but I can’t change them from 2775 or -w- rwx rwx r-x. So is there a tutorial on how to create a new page with this if I can’t do it from the admin.

Viewing 15 replies - 1 through 15 (of 27 total)
  • I know this is not helpfull to resolving your problem, but it works for me

    and I am using mod-_rewrite and permalinks

    Have you tried copying the rewrite rules to your .htaccess file and uploading it instead of having WP do it?

    How would i do that? I’m not even sure I can edit the .htaccess file. Last time I tried downloading it and viewing it… it was blank. Sorry I am completely new to blogs.


    If it was blank, then it doesn’t sound like WP is updating the file, so you must not have the correct permissions on it.

    If you’ve never put anything into a .htaccess file by yourself, you can simply create one on your local computer and upload it. You’ll need to go into your WP admin ->Options->permalinks and at the bottom should be a big box with a bunch of rewrite rules in it. Copy everything in there, paste it into a file called .htaccess and upload it to the root of your site. That should do that trick.

    I don’t see any rewrite rules when I go there… just see examples and all the fields are emtpy.
    If you want to see I could show you somehow.
    When I went to “Manage > Files > htaccess” it shows just
    Options -Indexes

    Is this bad?

    If all of the fields are empty, then you don’t have permalinks turned on and pages will not work.

    At least I don’t think pages will work in the way that you’d want them to without permalinks.

    So whats my solution?

    you can see what i mean there.

    you need to go into the permalinks section under wp-admin and then put your fields into those boxes.
    like if you want just the category name and date to work.
    then once you hit ok, it will give you the code that needs to be inserted into your .htaccess file
    I had a blank one on my root file for my site. so i downloaded it. added the code when i opened it with notepad then uploaded it to the my root folder for the wordpress install.

    and also when you upload it. make sure the .htaccess file is 777 chmod so that when you create new pages it will write to the file.

    ok i messed up… i put /%year%/%monthnum%/%day%/%postname%/ and hit update permalink now none of the links on the main page work… I don’t understand what i did.

    Can someone look at my site and see what i did wrong? First the pages weren’t working… now the links are all broke. I’m sorry, just new to “blog” terminology…. I worked with forums to long i think.

    After you update the permalink structure, you have to update your .htaccess with the list of rules that it gives you at the bottom.

    It didn’t give me any rules… After I updated it, I went to Manage>Files and viewed the .htaccess and it had a huge list of rewrite rules on it.

    Ok…so you have it setup to update .htaccess on your own. Can we get a link to your site to see what you are talking about?

    Edit: Whoops…didn’t see it up there since it wasn’t linked.

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Pages Not Working wp1.5’ is closed to new replies.