Support » Fixing WordPress » Pages not working – but visible through Admin panel

  • Hello everyone,

    I’ve a strange problem. Since a couple of days, one of my blogs stopped working regularly. In particular, I can see all the pages through the Admin panel, but as soon as I click on “View page” or when I try to browse the blog as a guest, I get the “Page not found” error. That happen only to pages, the homepages works just fine.

    The error started to show up after an issue with the MySql database. This wasn’t available for 24 hours, but was then reactivated by the hosting service provider. The other blogs, using the same database, work fine – only one has started to have this weird issue. I couldn’t find any thread about this specific issue. Have you got any idea what the technical reason could be?

    Thank you in advance and have a gerat Sunday.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Sorry guys, I’m really struggling here. I’ve also tried to delete the page and create it again from scratch, but I get the same error”404 Page not found”. Any idea?

    esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – resetting your custom permalinks back to the default setting via Settings -> Permalinks.

    This almost sounds like a permalink issue, what is your permalink structure?

    Also, are you running on Apache or IIS?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Pages not working – but visible through Admin panel’ is closed to new replies.