WordPress.org

Forums

[resolved] Pages not showing up (9 posts)

  1. randski
    Member
    Posted 9 years ago #

    I just upgraded to 2.0 and everything appears to be working fine, except my pages are not showing up. Example: http://preciousillusion.com/art

    Except that when I go to Manage > Pages, I can see them all. I can edit them too, it's just that they're not appearing on the site. I tried editing a page and hitting publish, but it didnt work.

    Is there a solution for this?

    Thanks

  2. GwynPerry
    Member
    Posted 9 years ago #

    I was having the same problem. I found this post whilst searching for a more elegant solution.

    My solution was to add individual rewrite rules for each page, based on their database ID. I'm on IIS with ISAPI_rewrite, instead of the usual Apache with Mod_rewrite. This is an example from my httpd.ini (if you are on Apache, look in .htaccess):

    RewriteRule /about/ /?page_id=3 [I,U,O]

    One rule for each page, and new rules are needed when new pages are created.
    It's now working for me. Hope this helps

  3. randski
    Member
    Posted 9 years ago #

    I'm sorry, I'm not extremely savvy in this, so I'm not sure if I understood that. What you're basically saying is that I have to add the line above to my .htaccess file for each individual page (replacing the 3 with the actual page numbers, of course)?

  4. moshu
    Member
    Posted 9 years ago #

    Not in 2.0.
    Even in Wp 1.5.x you just had to make the .htaccess writable (=cmod 666) and WP used to write the rules for every new Page.

    Did you update your htaccess file after the upgrade? After downloading the old .htaccess file I'd upload an empty new one and let WP to write it for 2.0.
    However, you should be aware there are bugs with the permalinks in 2.0.

  5. GwynPerry
    Member
    Posted 9 years ago #

    As I said, that was what worked for me, and I'm looking for a more elegant solution. I am using WP2.0, but I'm a new user this week, so I don't know a great deal about it. I needed a quick fix, and this was the best I could do.

    First, I would check to see if permalinks are in fact the problem. Go to the admin page, then Options >> Permalinks. Choose the default option (?p=123). Copy down your custom string first if you don't want to lose it. Now test your site. Are pages working? They were for me.

    What moshu said (replace current .htaccess file with empty, writable one, then update permalinks) is probalby the way to go. This is actually what I tried before my host informed me that they'd 'upgraded' they're servers to IIS without telling me.

    Moshu, do you know where in the WP code the permalinks are created? I may be able to adapt the code to produce ISAPI_rewrite rules in an httpd.ini file. I'd be happy to host such a modification on my site. (I'm guessing that WP currently only does mod_rewrite in .htaccess).

  6. randski
    Member
    Posted 9 years ago #

    Well, I emptied the .htaccess file and cmoded it, and it's still not working. I'm guessing its not a problem with the permalinks because I changed them back to the default and the pages were still empty.

    Btw, thanks for the help guys :)

  7. randski
    Member
    Posted 9 years ago #

    Bumping coz my problem is still not fixed.

  8. randski
    Member
    Posted 9 years ago #

    Okay, I finally solved my problem. I just re-uploaded my old .htaccess file that had all the rewrite rules on it and the pages are all working now.

  9. kmsiever
    Member
    Posted 9 years ago #

    I just started using pages. However, when I try to go to the page http://www.domain.com/page-name/ it says the page cannot be found.

    If I overwrite the .htaccess file with that in the permalinks options admin page, then my pages show up; however, it makes my author pages not display information such as names, websites, profiles, etc.

    When I upload my old .htaccess file, the author pages appear again, but then the pages file "go missing".

    Any ideas? I am using WordPress 2.0.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.