WordPress.org

Support

Support » Themes and Templates » [Resolved] Pages not displaying anything

[Resolved] Pages not displaying anything

  • This may be a silly question but I can’t get my head round it at the moment, the pages in the theme I’m developing are failing to display anything – and I mean anything, no HTML, no content, no nothing.
    My page.php file looks like this at the moment (I took it right back down to basics and still nothing), any advice would be much appreciated!:

    <?php get_header(); ?>

    <?php get_sidebar(); ?>

    <div id=”content”>

    <?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    <div class=”post” id=”post-<?php the_ID(); ?>”>
    <h2><?php the_title(); ?></h2>
    <div class=”entry”>
    <?php the_content(‘<p class=”serif”>Read the rest of this page »</p>’); ?>

    <?php wp_link_pages(array(‘before’ => ‘<p>Pages: ‘, ‘after’ => ‘</p>’, ‘next_or_number’ => ‘number’)); ?>

    </div>
    </div>
    <?php endwhile; endif; ?>
    <?php edit_post_link(‘Edit this entry.’, ‘<p>’, ‘</p>’); ?>

    <?php comments_template(); ?>

    </div>

    <?php get_footer(): ?>

Viewing 1 replies (of 1 total)
  • argh i’m so stupid! hadn’t noticed until just now that i’d closed the get_footer function with a colon rather than a semi-colon so the whole lot was failing, replaced that and everything is fine!

    doh!

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Pages not displaying anything’ is closed to new replies.
Skip to toolbar