Support » Plugin: Language Switcher » Plugin heavily bugged

  • For some reason the bugs in the plugin also reach the admin panel.
    That is, when I edit any page in any language, they are always shown as being in ENGLISH.

    At the actual website, pages are shown in the selected language, but the sidebar language list considers ALL pages as ENGLISH instead of selecting the current language.

    Opening the site in a private tab seems to fix everything. This plugin has some serious bugs with its cache/cookies/localStorage management, please review that if possible, thanks.

    • This topic was modified 8 months, 2 weeks ago by inuya5ha.
    • This topic was modified 8 months, 2 weeks ago by inuya5ha.
    • This topic was modified 8 months, 2 weeks ago by inuya5ha.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author rafasashi

    (@rafasashi)

    Thank you for the feedback.

    If you are using multiple languages in one WP installation the plugin uses cookies to keep track of the last language switched to set the global language and core translations accordingly.

    The plugin as an option to disable Cookies if you are not interested or if it doesn’t perform well.

    In the second case please feed me back with more details because I can’t reproduce the error.

    What is the main/default language for you site? (the language you expect the admin dashboard to use)

    What do you mean by “the sidebar language list considers ALL pages as ENGLISH ” because I can’t see any sections or keywords in your sidebar that is usually translated by the core translation system such as “categories”, “tags”, “comments”… Do you expect the plugin to translate the words you have added from widget settings?

    I remain at your disposal.

    Kindly,
    Raphael

    Thread Starter inuya5ha

    (@inuya5ha)

    Thanks for your reply. All pages are in english except the one shown as Media Subtitler in the header navigation, such page is available in 20 languages.

    Problem is, whenever I open the translated page to any language, the sidebar Language widget still shows English with bold font, instead of the current page’s language.

    Please see this sreenshot:
    https://ibb.co/QPq0S9B

    The shown page there is the French translation, and French should be in bold, not English. It works correctly only in private tabs, however.

    • This reply was modified 8 months, 1 week ago by inuya5ha.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugin heavily bugged’ is closed to new replies.