WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Pages don't show

[Resolved] Pages don't show

  • Hello! A newb to WP stuff and I’ve run into a problem where the pages won’t show up anymore, and the header menu bar won’t show any of the tabs to the pages. although I can see the pages and page tabs when I’m logged into the Admin account, when I access the website on a computer that’s not logged in, there’s nothing. The pages do show up in the dashboard’s page managing area as “published” and “public”. Here’s the site:
    http://www.computreksystems.com/remote

    I’ve tried a couple of fixes I’ve found here on the forums, but none have worked so far. I first tried to insert them with this line in the header.php file, adding the page ID number be the the “title_li” as directed here in the codex wiki, as directed to by a member here:
    http://codex.wordpress.org/Template_Tags/wp_list_pages#Examples

    <?php wp_list_pages(‘title_li= ‘); ?>

    Didn’t work.

    Then tried to reset the permalinks, but nada. In fact, I can’t even find the .htaccess file regardless to delete. When I accessed my MySql database, the wp_config file wasn’t there.

    My host is Yahoo, and I’ve heard there can be some issues with there control panel. Am I doing something wrong?

    Please help x_x Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    I thought Yahoo does not allow .htaccess files.

    Yahoo! does not currently allow you to upload .htaccess files to your account.

    http://help.yahoo.com/l/us/yahoo/smallbusiness/webhosting/glossary/glossary-08.html

    Was this site ever working on your Yahoo hosting?

    If you turn off pretty permalinks and go with the defaults, is there any change?

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    p.s.

    When I accessed my MySql database, the wp_config file wasn’t there.

    The wp-config.php file should be visible when you FTP to your server, in the folder where you installed WordPress.

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    p.p.s. did you use Yahoo’s automated WordPress installer, referenced here?

    http://help.yahoo.com/l/us/yahoo/smallbusiness/webhosting/wordpress/wordpress-03.html

    If so, have you tried contacting them for help?

    What do you know, the one place I forgot to search for htaccess info lol.

    Was this site ever working on your Yahoo hosting?
    If you turn off pretty permalinks and go with the defaults, is there any change?

    Yes, it was working before. I did switch to default permalinks, but nothing. I even thought I might had messed something up in the page settings, so I just remade them all, but nada.

    p.p.s. did you use Yahoo’s automated WordPress installer, referenced here?
    If so, have you tried contacting them for help?

    Yes, and yes. They said they don’t offer support for WordPress, and directed me back here.

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    That is really, really, poor customer support. Can you switch to another host?

    p.s. I don’t get how pretty permalinks could ever have worked without an .htaccess file on your server. You’re on a Linux plan, not Windows?

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    Have you tried turning off all plug-ins to rule out a plug-in issue?

    Have you tried switching briefly to the default Twenty Ten theme to rule out a theme issue? (You may need to reset your widgets after.)

    Would change hosts, but my client was specific about staying with Yahoo for the time being.

    Windows.

    The pretty permalinks only worked for a couple days when I first started editing the site. After the fact that Yahoo doesn’t allow the .htaccess file, I’m confused too.

    Have you tried turning off all plug-ins to rule out a plug-in issue?

    Have you tried switching briefly to the default Twenty Ten theme to rule out a theme issue? (You may need to reset your widgets after.)

    hmmm, will try that. brb

    Plug-in issue. Thanks!

    Moderator Kathryn

    @zoonini

    Automattic Happiness Engineer

    Glad you got it fixed. Do you know which plug-in was the culprit? It may help others.

    Most Windows servers don’t use .htaccess (they have another redirection mechanism instead) so that probably explains the other mystery.

    If you would please mark this thread as “resolved” (drop-down menu in the right column) it would be appreciated. Helps everyone keep better track of whose issues are still outstanding. Thanks!

    Looks like these yahoo plugins:

    Yahoo! Web Hosting Warning Messages
    Yahoo! Web Hosting Masthead

    I ran into this on my RN to BSN Online Programs site. I cannot tell you how much I freaked out.
    They were all there in the DB but could not see any page, published or not in the management screen.

    Here is what I did:
    I switched permalinks to default, saved.
    Deactivated ALL plugins.
    Switched permalinks back to my custom.

    Whammo, the pages showed. Hope it helps someone.

    RTBOP

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Pages don't show’ is closed to new replies.
Skip to toolbar